POJ 3616 Milking Time

时间:2022-07-28
本文章向大家介绍POJ 3616 Milking Time,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Milking Time

Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 15650 Accepted: 6644 Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours. Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2 1 2 8 10 12 19 3 6 24 7 10 31 Sample Output

43 题目比较简单直接上代码:

#include<cstring>
#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct obj{
long long int st,en,val;
} ob[1050];
long long int dp[1050];
bool cmp(obj a,obj b)
{
    if(a.st==b.st) return a.en<b.en;
    return a.st<b.st;
}
int main()
{
    long long int cap,lis,re,tem1,tem2,ans;
    while(cin>>cap>>lis>>re){
            ans=0;
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=lis;i++) scanf("%d%d%d",&ob[i].st,&ob[i].en,&ob[i].val);
        sort(ob+1,ob+lis+1,cmp);
        for(int i=1;i<=lis;i++){
                tem1=tem2=0;
            dp[i]=ob[i].val;
            for(int t=i;t>=1;t--){
                if(ob[i].st>=ob[t].en+re)
                    dp[i]=max(dp[i],dp[t]+ob[i].val);
            ans=max(ans,dp[i]);
            }
        }
        // for(int i=1;i<=lis;i++) cout<<dp[i]<<' ';
        printf("%ldn",ans);
    }
    return 0;
}