PAT (Advanced Level) Practice 1029 Median (25分)

时间:2022-07-26
本文章向大家介绍PAT (Advanced Level) Practice 1029 Median (25分),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

1029 Median (25分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

题意:给定两个非递减序列,求两个序列合并之后的中位数,这里说的合并序列是不去重的

太水了8?直接两个序列塞入向量里,排个序,如果是偶数,输出第【向量长度/2-1】个元素,否则输出第【向量长度/2】个元素

为什么?你简单用纸和笔演算一下就明白了....

#include<bits/stdc++.h>
using namespace std;
int m,n;

int main()
{   vector<long long>v;
    ios::sync_with_stdio(false);
    cin>>m;
    for(int i=1;i<=m;i++)
    {
        long long x;
        cin>>x;
        v.push_back(x);
    }
    cin>>n;
    for(int i=1;i<=n;i++)
    {
        long long  x;
        cin>>x;
        v.push_back(x);
    }
    sort(v.begin(),v.end());
    v.size()%2?cout<<v[v.size()/2]<<endl:cout<<v[v.size()/2-1]<<endl;
    while(1)getchar();
    return 0;
}