贪心-HDU1789 Doing Homework again(活动安排问题)

时间:2022-07-25
本文章向大家介绍贪心-HDU1789 Doing Homework again(活动安排问题),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

目录

  • 题目
    • 题意
    • 分析
    • 代码

题目


传送门: HDU-1789

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

input:

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

output:

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input:

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output:

0
3
5

题意

给出N个作业的截止日期和未完成的罚分,每天只能完成一个作业,求最小的罚分。

分析

首先把作业按截止日期从小到大排序,如果日期相同按罚分降序,我们希望完成尽可能多的作业。然而仅靠日期排序并不是最优的,当一项作业超过截止日期时,我们不能就简单的加上罚分,我们要把它的罚分和前面完成作业的最小罚分相比(优先队列实现),选择罚分较小的那个。

代码

#include<cstdio>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 1003;
int t, n;
pair<int, int>p[maxn];
bool cmp(pair<int, int>a, pair<int, int>b) {
	if (a.first == b.first)
		return a.second > b.second;
	else return a.first < b.first;
}
struct cmp2 {
	bool operator()(pair<int, int>a, pair<int, int>b) {
		return a.second > b.second;

	}
};
int main() {
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d", &p[i].first);
		for (int i = 0; i < n; i++)
			scanf("%d", &p[i].second);
		sort(p, p + n, cmp);//按日期升序罚分降序
		int ans = 0, day = 1;
		priority_queue<pair<int, int>,vector<pair<int, int>>, cmp2>q;
		for (int i = 0; i < n; i++)
			if (p[i].first < day) {//逾期
				if (q.top().second < p[i].second) {//和之前罚分最小的比较
					ans += q.top().second;
					q.pop();
					q.push(p[i]);
				}
				else ans += p[i].second;
			}
			else {
				q.push(p[i]);//入队
				day++;
			}
		printf("%dn", ans);
	}
	return 0;
}

原创不易,请勿转载本不富裕的访问量雪上加霜 ) 博主首页:https://blog.csdn.net/qq_45034708