HDU 5675 ztr loves math

时间:2022-05-11
本文章向大家介绍HDU 5675 ztr loves math,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

ztr loves math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 133    Accepted Submission(s): 64

Problem Description

ztr loves research Math.One day,He thought about the "Lower Edition" of triangle equation set.Such as . He wanted to know that ,for a given number n,is there a positive integer solutions?

Input

There are T test cases.  The first line of input contains an positive integer  indicating the number of test cases. For each test case:each line contains a positive integer ,.

Output

If there be a positive integer solutions,print ,else print 

Sample Input

4
6
25
81
105

Sample Output

False
True
True
True
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string>
#include <map>

using namespace std;
__int64 n;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {

    scanf("%I64d",&n);
    if((n&1))
    {
        if(n==1)
        {
             printf("Falsen");
            continue;
        }
        else
            {printf("Truen");continue;}
    }
    else
    {
        if(n%4==0&&n!=4)
        {
            printf("Truen");
            continue;
        }
        else
        {
            printf("Falsen");
            continue;
        }
    }
    }
    return 0;
}