POJ----The Suspects

时间:2022-05-05
本文章向大家介绍POJ----The Suspects,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

The Suspects

Time Limit: 1000MS

Memory Limit: 20000K

Total Submissions: 18890

Accepted: 9150

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). Once a member in a group is a suspect, all members in the group are suspects. However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

Source

Asia Kaohsiung 2003

代码:

#include<iostream>
#include<cstdio>
#define maxn 30002
using namespace std;
int Father[maxn],rank[maxn];
void makeset(int n)                      //初始化
{
    for(int i=0;i<n;i++)
    {
        Father[i]=i;                     //以自身做根
        rank[i]=1;                      //开始高度为1
    }
}
int findset(int x)
{
    if(x!=Father[x])
    {
        Father[x]=findset(Father[x]);
    }
    return Father[x];
}

void unionset(int fx,int fy)
{
    fx=findset(Father[fx]);
    fy=findset(Father[fy]);
    if(fx==fy)
        return ;
    if(rank[fx]>rank[fy])         
    {
        Father[fy]=fx;
        rank[fx]+=rank[fy];
    }
    else
    {
        Father[fx]=fy;
        rank[fy]+=rank[fx];
    }
}
int main()
{
  int n,m,k,st,num;
  while(scanf("%d%d",&n,&m),n+m)
  {
      makeset(n);
      while(m--)
      {
       scanf("%d%d",&k,&st);
       while(--k)
       {
        scanf("%d",&num);
        unionset(st,num);
       }
      }
    printf("%dn",rank[findset(0)]);
  }
  return 0;
}