HDU 4764 Stone(巴什博奕)

时间:2022-05-08
本文章向大家介绍HDU 4764 Stone(巴什博奕),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Problem Description

Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.

Input

There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.

Output

For each case, print the winner's name in a single line.

Sample Input

1 1 30 3 10 2 0 0

Sample Output

Jiang Tang Jiang

Source

2013 ACM/ICPC Asia Regional Changchun Online

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6263 6262 6261 6260 6259

我们可以把模型抽象一下

有n-1个石子,一个人最多拿k个,问最后谁赢

——》裸的巴什博奕

#include<cstdio>
#include<algorithm>
using namespace std;
const int MAXN=1e6+10,INF=1e9+10;
int main()
{
    #ifdef WIN32
    freopen("a.in","r",stdin);
    #else
    #endif
    int x,y;
    while(scanf("%d%d",&x,&y))
    {
        if(x==0&&y==0) break;
        if( (x-1)%(y+1)==0 ) printf("Jiangn");
        else                  printf("Tangn");
    }
    return 0;
}