hdu 1541 Stars 统计<=x的数有几个

时间:2019-09-23
本文章向大家介绍hdu 1541 Stars 统计<=x的数有几个,主要包括hdu 1541 Stars 统计<=x的数有几个使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15951    Accepted Submission(s): 5945


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 
Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 
Sample Input
5
1 1
5 1
7 1
3 3
5 5
 
Sample Output
1
2
1
1
0
题意:给n个坐标,这些坐标按y值从小到大给出,每个坐标的等级就是在【0,0】~【x,y】区域内点的个数,输出每个等级有多少个点
题解:因为y是有序的,只考虑x就可以了,所以每个点的等级就是:之前输入的坐标x(0~i)中,x的值<=x的点有几个
再用vis[]统计每个等级的点有几个即可
 

 注意:航电里面的数据范围少了一个0,0<= x,y <=320000

#include<iostream>
#include<string.h>
#include<string>
#include<algorithm>
using namespace std;
int b[320005],vis[150005];
int lowbit(int x)//x的二进制表达中,从右往左第一个1所在的位置表示的数,返回的是这个数的十进制数
{
    return x&(-x);
}
void add(int x)
{
    while(x<=320000)
    {
        b[x]++;
        x=x+lowbit(x);
    }
}
int getnum(int x)
{
    int cnt=0;
    while(x>0)
    {
        cnt=cnt+b[x];
        x=x-lowbit(x);
    }
    return cnt;
}
int main()
{
    int t,x,y;
    while(~scanf("%d",&t))
    {
        memset(vis,0,sizeof(vis));
        memset(b,0,sizeof(b));
        for(int i=0;i<t;i++)
        {
            scanf("%d%d",&x,&y);
            vis[getnum(x+1)]++;//统计<=x的数有几个
            add(x+1);
        }
        for(int i=0;i<t;i++)
            printf("%d\n",vis[i]);
    }
}

原文地址:https://www.cnblogs.com/-citywall123/p/11573253.html