Battle ships(HDU-5093)

时间:2019-01-18
本文章向大家介绍Battle ships(HDU-5093),主要包括Battle ships(HDU-5093)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Problem Description

Dear contestant, now you are an excellent navy commander, who is responsible of a tough mission currently. 

Your fleet unfortunately encountered an enemy fleet near the South Pole where the geographical conditions are negative for both sides. The floating ice and iceberg blocks battleships move which leads to this unexpected engagement highly dangerous, unpredictable and incontrollable. 

But, fortunately, as an experienced navy commander, you are able to take opportunity to embattle the ships to maximize the utility of cannons on the battleships before the engagement. 

The target is, arrange as many battleships as you can in the map. However, there are three rules so that you cannot do that arbitrary: 

A battleship cannot lay on floating ice 
A battleship cannot be placed on an iceberg 

Two battleships cannot be arranged in the same row or column, unless one or more icebergs are in the middle of them. 

Input

There is only one integer T (0<T<12) at the beginning line, which means following T test cases. 

For each test case, two integers m and n (1 <= m, n <= 50) are at the first line, represents the number of rows and columns of the battlefield map respectively. Following m lines contains n characters iteratively, each character belongs to one of ‘#’, ‘*’, ‘o’, that symbolize iceberg, ordinary sea and floating ice.

Output

For each case, output just one line, contains a single integer which represents the maximal possible number of battleships can be arranged.

Sample Input

2
4 4
*ooo
o###
**#*
ooo*
4 4
#***
*#**
**#*
ooo#

Sample Output

3
5

————————————————————————————————————————————

题意:有一个 n*m 的图,* 代表空白海域,# 代表冰山,o 代表浮冰,在海域上布置战船,要求战船不能放到浮冰、冰山上,每一行每一列只能布置一艘船,除非中间有冰山隔开,问最多能布置多少艘

思路:同一行列只能放置一艘船,很容易想到二分图的最大匹配,但由于冰山的存在使得每一行列有可能放置两艘船,因此可以将行列作为两个集合,每一行或每一列分别对应集合的一个点,遇到冰山时,将行列进行拆点建图,最后匈牙利算法跑一遍即可。

Source Program

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
#define PI acos(-1.0)
#define E 1e-6
#define MOD 1000003
#define INF 0x3f3f3f3f
#define N 1001
#define LL long long
using namespace std;
int n,m;
int G[N][N];
char str[N][N];
int x[N][N],y[N][N];
int link[N];
bool vis[N];
int cntX,cntY;
bool dfs(int u){
    for(int i=1;i<cntY;i++){
        if(G[u][i]&&!vis[i]){
            vis[i]=true;
            if(link[i]==-1 || dfs(link[i])){
                link[i]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary(){
    int res=0;
    memset(link,-1,sizeof(link));
    for(int i=1;i<cntX;i++){
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            res++;
    }
    return res;
}
int main (){
    int t;
    scanf("%d",&t);
    while(t--){
        memset(G,0,sizeof(G));
        memset(x,0,sizeof(x));
        memset(y,0,sizeof(y));

        scanf("%d%d",&n,&m);
        for(int i=0;i<n;i++)
            scanf("%s",str[i]);

        //处理行
        cntX=1;
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(str[i][j]=='*')
                    x[i][j]=cntX;
                if(str[i][j]=='#')
                    cntX++;
            }
            cntX++;
        }

        //处理列
        cntY=1;
        for(int j=0;j<m;j++){
            for(int i=0;i<n;i++){
                if(str[i][j]=='*')
                    y[i][j]=cntY;
                if(str[i][j]=='#')
                    cntY++;
            }
            cntY++;
        }


        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
                if(str[i][j]=='*')
                    G[x[i][j]][y[i][j]]=1;

        printf("%d\n",hungary());
    }
    return 0;
}