POJ 3311 Hie with the Pie 【状压DP】

时间:2019-04-19
本文章向大家介绍POJ 3311 Hie with the Pie 【状压DP】,主要包括POJ 3311 Hie with the Pie 【状压DP】使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

最短Hamilton路径的变形

区别就是要先用Floyd跑一遍最短路,然后从0出发最后还得回到0;

#include <iostream>
#include <cstdio>       //EOF,NULL
#include <cstring>      //memset
#include <cmath>        //ceil,floor,exp,log(e),log10(10),hypot(sqrt(x^2+y^2)),cbrt(sqrt(x^2+y^2+z^2))
#include <algorithm>    //fill,reverse,next_permutation,__gcd,
#include <string>
#include <vector>
#include <queue>
#include <stack>
#include <map>
using namespace std;
#define rep(i, a, n)		for (int i = a; i < n; ++i)
#define sca(x)			scanf("%d", &x)
#define sca2(x, y)		scanf("%d%d", &x, &y)
#define sca3(x, y, z)		scanf("%d%d%d", &x, &y, &z)
#define pri(x)			printf("%d\n", x)
#define pb	push_back
#define mp	make_pair
typedef pair<int, int>		P;
typedef long long		ll;
const int INF = 0x3f3f3f3f;
int dp[1 << 11][20];
int n;
int a[20][20];
int main()
{
	while(sca(n) && n){
    n += 1;
    for (int i = 0; i < n; i++)
    {
      for (int j = 0; j < n; j++)
      {
        sca(a[i][j]);
      }
    }
    for(int k = 0; k < n; k++){
      for(int i = 0; i < n; i++){
        for(int j = 0; j < n; j++)
          a[i][j] = min(a[i][j],a[i][k] + a[k][j]);
      }
    }
    memset(dp, 0x3f, sizeof dp);
    dp[1][0] = 0;
    for (int i = 0; i < 1 << n; i++)
    {
      for (int j = 0; j < n; j++)
      {
        if (i >> j & 1) {
          for (int k = 0; k < n; k++)
          {
            if ((i ^  1 << j) >> k & 1) {
              dp[i][j] = min(dp[i][j], dp[i^1 << j][k] + a[k][j]);
            }
          }
        }
      }
    }
    int ans = INF;
    for(int j = 0; j < n; j++){
        ans = min(ans,dp[(1<<n)-1][j] + a[j][0]);
    }
    pri(ans);
  }
}