POJ 2188 Cow Laundry

时间:2022-07-28
本文章向大家介绍POJ 2188 Cow Laundry,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Cow Laundry Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 1376 Accepted: 886 Description

The cows have erected clothes lines with N (1 <= N <= 1000) wires upon which they can dry their clothes after washing them. Having no opposable thumbs, they have thoroughly botched the job. Consider this clothes line arrangement with four wires:

Wire slot: 1 2 3 4

          ---------------   <-- the holder of the wires

                /    /

               /    /

               /   /       

              /   /       <-- actual clothes lines

              /    

             /   / 

            /   /   

           /    /    

          /    /      

          ---------------   <-- the holder of the wires

Wire slot: 1 2 3 4

The wires cross! This is, of course, unacceptable.

The cows want to unscramble the clothes lines with a minimum of hassle. Even their bovine minds can handle the notion of “swap these two lines”. Since the cows have short arms they are limited to swapping adjacent pairs of wire endpoints on either the top or bottom holder. In the diagram above, it requires four such swaps in order to get a proper arrangement for the clothes line:

          1   2   3   4

          -------------   <-- the holder of the wires

          |   |   |   |

          |   |   |   |

          |   |   |   |

          |   |   |   |

          |   |   |   |

          |   |   |   |

          |   |   |   |

          |   |   |   |

          |   |   |   |

          -------------   <-- the holder of the wires

          1   2   3   4

Help the cows unscramble their clothes lines. Find the smallest number of swaps that will get the clothes line into a proper arrangement.

You are supplied with clothes line descriptions that use integers to describe the current ordering of the clothesline. The lines are uniquely numbered 1…N according to no apparent scheme. You are given the order of the wires as they appear in the N connecting slots of the top wire holder and also the order of the wires as they appear on the bottom wire holder. Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Each line contains two integers in the range 1…N. The first integer is the wire ID of the wire in the top wire holder; the second integer is the wire ID of the wire in the bottom holder. Line 2 describes the wires connected to top slot 1 and bottom slot 1, respectively; line 3 describes the wires connected to top and bottom slot 2, respectively; and so on.

Output

  • Line 1: A single integer specifying the minimum number of adjacent swaps required to straighten out the clothes lines. Sample Input

4 4 1 2 3 1 4 3 2 Sample Output

4 Source

USACO 2003 Fall Orange

找到规律的话就是求有多少逆序对,还是比较好想的,但是要处理的话,这个逆序是相对于开始状态,不是另一端点,代码比较简单,思维题,签到题)

#include<iostream>
#include<map>
using namespace std;
int ob[1005];
int oj[1005];
map<int,int>w;
int main()
{
    int n;
    w.clear();
    cin>>n;
    for(int i=0;i<n;i++){
        cin>>ob[i]>>oj[i];
        w.insert(make_pair(ob[i],i));
    }
    int ans=0;
    for(int i=0;i<n;i++)
        for(int j=i+1;j<n;j++)
        if(w[oj[i]]>w[oj[j]])  ans++;
    cout<<ans<<endl;
}