POJ 1789 Truck History 最小生成树

时间:2022-07-28
本文章向大家介绍POJ 1789 Truck History 最小生成树,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types. Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

感觉做了一天的水题,这个题还是考察建图,图论就是建出图来你就赢了。这个题两点之间距离就是俩个字符串的不一样字符的个数,这题伴随着HASH或者KMP考察,应该会难一点,不过现在不卡超时,所以无敌模板,直接套。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=2005;
char str[maxn][7];
int pre[maxn];
struct truck
{
    int to;
    int from;
    int weight;
} pp[maxn*(maxn>>1)];
int n,qq,ans;
void init()
{
    ans=0;
    qq=0;
    for(int i=0; i<=n; i++)
        pre[i]=i;
}
bool cmp(truck a,truck b)
{
    return a.weight<b.weight;
}
int finds(int x)
{
    if(x==pre[x])
        return pre[x];
    pre[x]=finds(pre[x]);
    return pre[x];
}
void make_tree()
{
    for(int i=0; i<n; i++)
        for(int j=n-1; j>=i; j--)
        {
            int sum=0;
            for(int x=0; x<7; x++)
                if(str[i][x]!=str[j][x])
                    sum++;
            pp[qq].from=i;
            pp[qq].to=j;
            pp[qq].weight=sum;
            ++qq;
        }
}
void kruskal()
{
    sort(pp,pp+qq,cmp);
    int to,from;
    for(int i=0; i<qq; i++)
    {
        to=finds(pp[i].to);
        from=finds(pp[i].from);
        if(to==from);
        else if(to!=from)
        {
            pre[to]=from;
            ans+=pp[i].weight;
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0; i<n; i++)
            scanf("%s",str[i]);
        init();
        make_tree();
        kruskal();
        printf("The highest possible quality is 1/%d.n",ans);
    }
    return 0;
}