ACM-ICPC 2019 山东省省赛 M Sekiro

时间:2022-07-28
本文章向大家介绍ACM-ICPC 2019 山东省省赛 M Sekiro,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Sekiro: Shadows Die Twice is an action-adventure video game developed by FromSoftware and published by Activision. In the game, the players act as a Sengoku period shinobi known as Wolf as he attempts to take revenge on a samurai clan who attacked him and kidnapped his lord.

As a game directed by Hidetaka Miyazaki, Sekiro (unsurprisingly) features a very harsh death punishment. If the player dies when carrying amount of money, the amount of money will be reduced to , where indicates the smallest integer that .

As a noobie of the game, BaoBao has died times in the game continuously. Given that BaoBao carried amount of money before his first death, and that BaoBao didn’t collect or spend any money during these deaths, what’s the amount of money left after his deaths?

Input There are multiple test cases. The first line of the input contains an integer (about ), indicating the number of test cases. For each test case:

The first and only line contains two integers and (, ), indicating the initial amount of money BaoBao carries and the number of times BaoBao dies in the game.

Output For each test case output one line containing one integer, indicating the amount of money left after deaths.

Sample Input 4 10 1 7 1 10 2 7 2 Sample Output 5 4 3 2 Hint For the third sample test case, when BaoBao dies for the first time, the money he carries will be reduced from 10 to 5; When he dies for the second time, the money he carries will be reduced from 5 to 3.

除了2^31是int最大值,这一点。就是个签到题。大于31直接输出1,恭喜入坑,0的时候是零;

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        long long mon,op;
        scanf("%lld %lld",&mon,&op);
        if(mon==0) cout<<0<<endl;
        else if(op>31)cout<<1<<endl;
        else
        for(int i=0;i<op;i++)
        {
            if(mon%2==1) mon=mon/2+1;
            else mon/=2;
        }
        cout<<mon<<endl;
    }
    return 0;
}