POJ 2456 Aggressive cows

时间:2022-07-28
本文章向大家介绍POJ 2456 Aggressive cows,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Aggressive cows Time Limit: 1000MS Memory Limit: 65536K Total Submissions: 24838 Accepted: 11537 Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,…,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don’t like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance? Input

  • Line 1: Two space-separated integers: N and C
  • Lines 2…N+1: Line i+1 contains an integer stall location, xi Output
  • Line 1: One integer: the largest minimum distance Sample Input

5 3 1 2 8 4 9 Sample Output

3 Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended. Source

USACO 2005 February Gold

二分,看代码能懂,没什么坑~

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF = 1e9 + 5;
const int maxn = 1e5 + 5;
int n, k, x[maxn];
int check(int d)  
{
    int last = 0;
    for(int i = 1; i < k; i++) 
    {
        int cur = last + 1;  
        while(cur < n && x[cur] - x[last] < d)
            cur++;
        if(cur == n) return 0;
        last = cur;
    }
    return 1;
}
int main()
{
    while(~scanf("%d%d", &n, &k))
    {
        for(int i = 0; i < n; i++)
            scanf("%d", &x[i]);
        sort(x, x+n);
        int l = 0, r = INF;
        while(r - l > 1)
        {
            int mid = (l + r) / 2;
            if(check(mid)) l = mid;
            else r = mid;
        }
        printf("%dn", l);
    }
    return 0;
}