2019 ICPC 银川网络赛 D. Take Your Seat (疯子坐飞机问题)

时间:2022-07-28
本文章向大家介绍2019 ICPC 银川网络赛 D. Take Your Seat (疯子坐飞机问题),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Duha decided to have a trip to Singapore by plane.

The airplane had nn seats numbered from 11 to nn, and nn passengers including Duha which were also counted from 11 to nn. The passenger with number ii held the ticket corresponding to the seat with number ii, and Duha was the number 11 passenger.

All passengers got on the plane in the order of their numbers from 11 to nn. However, before they got on the plane Duha lost his ticket (and Duha was the only passenger who lost the ticket), so he could not take his seat correctly. He decided to take a seat randomly. And after that, while a passenger got on the plane and found that his/her seat has been occupied, he/she selected an empty seat randomly as well. A passenger except Duha selected the seat displayed in his/her ticket if it had not been occupied by someone else.

The first problem you are asked to calculate in this problem is the probability of the last passenger to get on the plane that took his/her correct seat.

Several days later, Duha finished his travel in Singapore, and he had a great time.

On the way back, he lost his ticket again. And at this time, the airplane had mm seats numbered from 11 to mm, and mm passengers including Duha which were also counted from 11 to mm. The passenger with number ii held the ticket corresponding to the seat with number ii, and Duha was the number 11 passenger as well.

The difference was that: all passengers got on the plane in a random order (which was any one of the mm! different orders with the same chance). Similarly, Duha or a passenger who found his/her seat had been occupied selected an empty seat randomly.

The second problem you are asked to calculate in this problem is the probability of the last passenger to get on the plane that took his/her right seat on the return trip.

Input

The input contains several test cases, and the first line is a positive integer TT indicating the number of test cases which is up to 5050.

For each test case, a line contains two integers nn and m (1 le n, m le 50)m(1≤n,m≤50).

Output

For each test case, output a line containing Case #x: y z, where xx is the test case number starting from 11, yy is the answer of the first problem, and zz is the answer of the second problem. Both of yy and zz are rounded to 66 places, and we guarantee that their 77-th places after the decimal point in the precise answer would not be 44 or 55.

输出时每行末尾的多余空格,不影响答案正确性

样例输入复制

1
2 3

样例输出复制

Case #1: 0.500000 0.666667

这个题,一场比赛下来,有人跑过来跟我说容斥定理,又有什么DFS的,这些全是抄题解,这不就是一个推公式的题目吗?队友推了很久,最后在一群人的指点江山下,自己推出公式;这个题就是一个疯子坐飞机概率问题:https://www.zhihu.com/question/35950050/answer/65272204

先讨论第一问,第一问的话,当这个呆瓜坐下,无论前N-1个怎么做,最后一个上来的人面对的是一个独立问题,是坐对或坐错,我们论证一下:

1、当只有两个人的时候,呆瓜是第一个,他有两种选择,作对坐不对,那么对于最后一个人,也有两种情况,坐对,坐错。

2、当只有三个人的时候,呆瓜是第一个,那么他有三种选择,1,2,3那么他有1/3的几率坐对,而只有他蠢,他坐对了,其他人都坐对了,在考虑其余2/3,那么对于当第一个人做了第二个人的位置,那么第二个人上来之后可以做第一个人的位置,也可以坐第三个人的位置,那么第三个人坐对的概率是1/2,在讨论,当第一个人做了第三个人的位置时,第三个人一定做不到自己的位置上,那么坐对坐不对的情况都是1/3+1/6=1/2。

3、那么当有四个人的时候,他坐在对于他做的四种情况都能推导到比他更低的人数的情况,而对于每种情况都是1/2,

那么第一问的答案永远都是1/2,那么我们考虑第二问,除了这个呆瓜之外,在他之前上来的肯定都坐对了,那么转化为第一种情况,除了一个人的时候是1之外,除了1/2之外还有第三种情况,是呆瓜最后上来,别人都坐对了,那他肯定也做对了,就是1,所以这个题的话就是有1/N的几率呆瓜最后上来,有N-1/N的情况是他在之前上来1/2的情况,那么答案即为 

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<iomanip>
using namespace std;
#define LL long long
#define MAXN 1000100
int main()
{
    int t,n,m,p=1;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        cout<<"Case #"<<p++<<": ";
        if(n==1)
            cout<<"1.000000"<<' ';
        else
            cout<<"0.500000"<<' ';
        cout<<fixed<<setprecision(6)<<(m+1)*1.0/(2*m)<<endl;
    }