数学--数论--HDU--5878 Count Two Three 2016 ACM/ICPC Asia Regional Qingdao Online 1001

时间:2022-07-28
本文章向大家介绍数学--数论--HDU--5878 Count Two Three 2016 ACM/ICPC Asia Regional Qingdao Online 1001,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
I will show you the most popular board game in the Shanghai Ingress Resistance Team.
It all started several months ago.
We found out the home address of the enlightened agent Icount2three and decided to draw him out.
Millions of missiles were detonated, but some of them failed.

After the event, we analysed the laws of failed attacks.
It's interesting that the i-th attacks failed if and only if i can be rewritten as the form of 2a3b5c7d which a,b,c,d are non-negative integers.

At recent dinner parties, we call the integers with the form 2a3b5c7d "I Count Two Three Numbers".
A related board game with a given positive integer n from one agent, asks all participants the smallest "I Count Two Three Number" no smaller than n.

Input

The first line of input contains an integer t (1≤t≤500000), the number of test cases. t test cases follow. Each test case provides one integer n (1≤n≤109).

Output

For each test case, output one line with only one integer corresponding to the shortest "I Count Two Three Number" no smaller than n.

Sample Input

10
1
11
13
123
1234
12345
123456
1234567
12345678
123456789

Sample Output

1
12
14
125
1250
12348
123480
1234800
12348000
123480000

这个题的意思是让你找到一个k大于n并且能写成 2 a 3 b 5 c 7 d 2^a3^b5^c7^d 2a3b5c7d这种形式。 然后就先把能写成这种形式的数的全部处理出来,在进行二分查找,比这个大的最小的数。

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
long long a[200000];
int d = 0;
int main()
{
    int x, y;
    d = 0;
    memset(a, 0, sizeof(a));
    for (int i = 0; i <= 32; i++)

    {
        for (int j = 0; j <= 19; j++)

        {
            for (int k = 0; k <= 12; k++)

            {
                for (int h = 0; h <= 11; h++)

                {
                    long long s = pow(2, i) * pow(3, j) * pow(5, k) * pow(7, h);
                    if (s > 1000000000 || s < 0)
                        break;
                    else
                    {
                        a[d++] = s;
                    }
                }
            }
        }
    }
    sort(a, a + d);
    scanf("%d", &x);
    while (x--)
    {
        scanf("%d", &y);
        printf("%lldn", *lower_bound(a, a + d, y));
    }
    return 0;
}