PAT (Advanced Level) Practice 1039 Course List for Student (25分)

时间:2022-07-26
本文章向大家介绍PAT (Advanced Level) Practice 1039 Course List for Student (25分),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

1039 Course List for Student (25分)

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤40,000), the number of students who look for their course lists, and K (≤2,500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N​i​​ (≤200) are given in a line. Then in the next line, N​i​​ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student's name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

题意:一看就是经典的题目了,给定n个人m门课,然后给出每门课选的学生名单,最后有k次查询,需要将每个学生的选课数和选的课编号输出

思路:做一map映射,unordered_map<string,set<int>>m,无序map主要为了节省时间,不加应该也能过?没试过,在给出名单的同时将每个学生所选的课存入其名字所对应的值,之所以选择set是因为set自动排序,最后输出即可~

#include<bits/stdc++.h>
#define ll long long
#define rg register ll
#define maxn 100005
using namespace std;
ll n,k,tot;
unordered_map<string,set<ll>>ans;
int main()
{   
    ios::sync_with_stdio(false);
    cin>>n>>k;
    for(rg i=1;i<=k;i++)
    {
        ll a,b;
        cin>>a>>b;
        for(rg i=1;i<=b;i++)
        {
            string q;
            cin>>q;
            ans[q].insert(a);
        }
    }
    for(rg i=1;i<=n;i++)
    {
        string a;
        cin>>a;
        ans[a].size()?cout<<a<<" "<<ans[a].size()<<" ":cout<<a<<" "<<ans[a].size()<<endl;
        ll cnt=0;
        for(auto it:ans[a])
        {
            cnt++;
            cnt==ans[a].size()?cout<<it<<endl:cout<<it<<" ";
        }

    }
    //while(1)getchar();
    return 0;
}