PAT (Basic Level) Practice (中文)1042 字符统计 (20 分)

时间:2022-07-26
本文章向大家介绍PAT (Basic Level) Practice (中文)1042 字符统计 (20 分),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

1042 字符统计 (20 分)

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过 1000 的字符串。字符串由 ASCII 码表中任意可见字符及空格组成,至少包含 1 个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:

This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........

输出样例:

e 7

思路很直啊,不区分大小写就是所有先转成小写再说,最后统计一遍出现在a到z之间的最大字符出现次数,输出这个字符和次数即可~

// luogu-judger-enable-o2
#include<bits/stdc++.h>
#include<unordered_set>
#define rg register ll
#define inf 2147483647
#define min(a,b) (a<b?a:b)
#define max(a,b) (a>b?a:b)
#define ll long long
#define maxn 300005
#define lb(x) (x&(-x))
const double eps = 1e-6;
using namespace std;
inline ll read()
{
	char ch = getchar(); ll s = 0, w = 1;
	while (ch < 48 || ch>57) { if (ch == '-')w = -1; ch = getchar(); }
	while (ch >= 48 && ch <= 57) { s = (s << 1) + (s << 3) + (ch ^ 48); ch = getchar(); }
	return s * w;
}
inline void write(ll x)
{
	if (x < 0)putchar('-'), x = -x;
	if (x > 9)write(x / 10);
	putchar(x % 10 + 48);
}
map<char,ll>p;
int main()
{
    string s;
    getline(cin,s);
    for(rg i=0;s[i];i++)
    {
        if(s[i]>='A'&&s[i]<='Z')s[i]+=32;
        p[s[i]]++;
    }
    ll maxx=-inf;
    char q;
    for(auto it:p)
    {
            if(maxx<it.second&&it.first>='a'&&it.first<='z')
            {
                maxx=it.second;
                q=it.first;
            }
    }
    cout<<q<<" "<<maxx<<endl;
   	return 0;
}