PAT List Leaves

时间:2022-06-17
本文章向大家介绍PAT List Leaves,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

4 1 5

题目大意:

       要求按照从上到下、从左到右的顺序输出所给树的叶子结点。输入第一行为结点个数,以下各行为每个结点的左孩子和右孩子的结点编号。例如,样例所表示的树为:

解题思路:

       1、建树。输入中带有字符‘-’,为了避免空白字符的干扰,采用cin输入最方便。建立结构体树的数组,该数组的编号就代表它是第几个结点,上图的结点编号就是树结构体数组,孩子编号就是树结构体数组里的内容,只需要找到树根就可以根据上图的表构建出树,树根的找法是孩子编号里没有的那个数就是根,上图孩子编号没有3,说明3是根结点。

2、层次遍历二叉树。其实就是宽度优先搜索,宽搜用队列实现,所以用一个数组q[]模拟队列即可,遍历的过程中把叶子结点打印出来。

代码如下:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

struct Tree
{
	char rchild, lchild;
	void clear()
	{
		rchild = 0;
		lchild = 0;
	}
};

Tree head[15];
int q[15];  //模拟队列 

int findRoot(Tree head[], int n)
{
	int isRoot[15];  //相当于布尔数组 
	char left, right;
	memset(isRoot, 0, sizeof(isRoot));
	for(int i = 0; i < n; i++)
	{
		left = head[i].lchild - '0';
		if(left >= 0)
			isRoot[left] = 1;
		right = head[i].rchild - '0';
		if(right >= 0)
			isRoot[right] = 1;
	}
	for(int i = 0; i < n; i++)
	{
		if(isRoot[i] == 0)
			return i;
	}
}

void bfs(Tree head[], int n, int root)
{
	int first = 1;//判断是不是第一个输出 
	int rear = 0, front = 0;//队列首尾 
	q[rear++] = root;
	while(front != rear)//当队列不为空 
	{
		if(head[q[front]].lchild != '-')
		{
			q[rear] = head[q[front]].lchild - '0';
			rear++;
		}
		if(head[q[front]].rchild != '-')
		{
			q[rear] = head[q[front]].rchild - '0';
			rear++;
		}
		if(head[q[front]].lchild == '-' && head[q[front]].rchild == '-')
		{
			if(first) 
			{
				cout << q[front];
				first = 0;
			}
			else
				cout << " " << q[front];
		} 
		front++;
	}
}

int main()
{
//	freopen("listLeaves.txt", "r", stdin);
	int n;
	int root;
	char c, d;
	while(scanf("%d", &n) != EOF)
	{
		for(int i = 0; i < n; i++)
			head[i].clear();
		memset(q, 0, sizeof(q));
		for(int i = 0; i < n; i++)
		{
			cin >> head[i].lchild >> head[i].rchild;
		}
		root = findRoot(head, n);
		bfs(head, n, root);
	}
	return 0;
}