HDU-1011 Starship Troopers(树形dp)

时间:2022-05-11
本文章向大家介绍HDU-1011 Starship Troopers(树形dp),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 15065 Accepted Submission(s): 4046

Problem Description You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern’s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers – the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1’s.

Output For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input 5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1

Sample Output 50 7

题意:就是一颗树,每一个结点有自己相应虫子数量,还有能量值,杀死虫子才能获得能量。一个士兵杀死20只虫子,问怎么样分配士兵才可以获得最多的能量,杀死父节点的虫子之后才能去扫荡子节点。 在这里,我对这道题目的理解是,树形dp,尤其是像这种类型的DP,其实就是背包问题的依赖背包变形。这道题目和这一道其实差不多的

背包九讲里讲过依赖背包,泛化物品。解决这种问题的方法就是从下而上,先解决子树的最优解,再由子树解决根的最优解。树形dp做到现在,基本上都是遵循这个规则,不同的就是状态转移方程发生一些变化

#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
int dp[105][105];//当前节点为i,小兵数为j得到的最大能量值
int n,m;
int bug[105];
int brain[105];
int head[105];
int tot;
int vis[105];
struct Node
{
    int value;
    int next;
}edge[105*2];
void add(int x,int y)
{
    edge[tot].value=y;
    edge[tot].next=head[x];
    head[x]=tot++;
}
void dfs(int root)
{
    vis[root]=1;
    int term=(bug[root]+19)/20;
    for(int i=term;i<=m;i++)
        dp[root][i]=brain[root];
    for(int i=head[root];i!=-1;i=edge[i].next)
    {
        int u=edge[i].value;
        if(!vis[u])
        {
            dfs(u);

            for(int j=m;j>=term;j--)
            {
                 for(int k=1;j+k<=m;k++)
                 {
                     if(dp[u][k])
                      dp[root][j+k]=max(dp[root][j+k],dp[root][j]+dp[u][k]);
                 }
            }
        }
    }
}
int main()
{
    int x,y;
   while(scanf("%d%d",&n,&m)!=EOF)
   {
       if(n==-1&&m==-1)
           break;
       memset(vis,0,sizeof(vis));
       memset(head,-1,sizeof(head));
       tot=0;
       memset(dp,0,sizeof(dp));
       for(int i=1;i<=n;i++)
       {
           scanf("%d%d",&bug[i],&brain[i]);
       }
       for(int i=1;i<n;i++)
       {
           scanf("%d%d",&x,&y);
           add(x,y);
           add(y,x);
       }
       dfs(1);
       if(m==0)
           printf("0n");
       else
           printf("%dn",dp[1][m]);
   }
}