POJ1509 Glass Beads(最小表示法 后缀自动机)

时间:2022-06-04
本文章向大家介绍POJ1509 Glass Beads(最小表示法 后缀自动机),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Time Limit: 3000MS

Memory Limit: 10000K

Total Submissions: 4901

Accepted: 2765

Description

Once upon a time there was a famous actress. As you may expect, she played mostly Antique Comedies most of all. All the people loved her. But she was not interested in the crowds. Her big hobby were beads of any kind. Many bead makers were working for her and they manufactured new necklaces and bracelets every day. One day she called her main Inspector of Bead Makers (IBM) and told him she wanted a very long and special necklace.  The necklace should be made of glass beads of different sizes connected to each other but without any thread running through the beads, so that means the beads can be disconnected at any point. The actress chose the succession of beads she wants to have and the IBM promised to make the necklace. But then he realized a problem. The joint between two neighbouring beads is not very robust so it is possible that the necklace will get torn by its own weight. The situation becomes even worse when the necklace is disjoined. Moreover, the point of disconnection is very important. If there are small beads at the beginning, the possibility of tearing is much higher than if there were large beads. IBM wants to test the robustness of a necklace so he needs a program that will be able to determine the worst possible point of disjoining the beads.  The description of the necklace is a string A = a1a2 ... am specifying sizes of the particular beads, where the last character am is considered to precede character a1 in circular fashion.  The disjoint point i is said to be worse than the disjoint point j if and only if the string aiai+1 ... ana1 ... ai-1 is lexicografically smaller than the string ajaj+1 ... ana1 ... aj-1. String a1a2 ... an is lexicografically smaller than the string b1b2 ... bn if and only if there exists an integer i, i <= n, so that aj=bj, for each j, 1 <= j < i and ai < bi

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly one line containing necklace description. Maximal length of each description is 10000 characters. Each bead is represented by a lower-case character of the english alphabet (a--z), where a < b ... z.

Output

For each case, print exactly one line containing only one integer -- number of the bead which is the first at the worst possible disjoining, i.e. such i, that the string A[i] is lexicographically smallest among all the n possible disjoinings of a necklace. If there are more than one solution, print the one with the lowest i.

Sample Input

4
helloworld
amandamanda
dontcallmebfu
aaabaaa

Sample Output

10
11
6
5

Source

题目大意:对于给定的字符串,输出其最小表示法的第一个字符在第几位

最小表示法:最小表示法又叫做最小循环表示。

你可以直观的理解为对于一个字符串,选一个位置把它劈开,把前一半接到后一半,形成一个新的字符串,在这些新的字符串中字典序最小的即为字符串的最小表示。

最小表示法有专门的算法(三指针法?https://www.cnblogs.com/XGHeaven/p/4009210.html)

但是它可以轻松的被SAM解决

我们先把SAM建出来,然后从根节点开始,每次走最小的转移边,走$|S|$次,所得的串即为最小表示

那么第一个字母可用通过$len-|S|$找到

#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 40001;
int N;
char s[MAXN];
int fa[MAXN], len[MAXN], ch[MAXN][26], tot = 1, last = 1, root = 1; 
void insert(int x) {
    int now = ++tot, pre = last; last = now; len[now] = len[pre] + 1;
    for(; pre && !ch[pre][x]; pre = fa[pre]) 
        ch[pre][x] = now;
    if(!pre) fa[now] = root;
    else {
        int q = ch[pre][x];
        if(len[q] == len[pre] + 1) fa[now] = q;
        else {
            int nows = ++tot; len[nows] = len[pre] + 1;
            memcpy(ch[nows], ch[q], sizeof(ch[q]));
            fa[nows] = fa[q]; fa[q] = fa[now] = nows;
            for(; pre && ch[pre][x] == q; pre = fa[pre]) ch[pre][x] = nows;
        }
    }
}
int main() {
#ifdef WIN32
    freopen("a.in", "r", stdin);
#endif
    int QwQ;
    scanf("%d", &QwQ);
    while(QwQ--) {
        memset(fa, 0, sizeof(fa));
        memset(ch, 0, sizeof(ch));
        memset(len , 0, sizeof(len));
        tot = last = root = 1;
        scanf("%s", s + 1);
        N = strlen(s + 1);
        for(int i = 1; i <= N; i++) s[i + N] = s[i];
        N <<= 1;
        for(int i = 1; i <= N; i++) insert(s[i] - 'a');
        int now = root, tot = 0;
        for(; tot <= N / 2; tot++) {
            for(int i = 0; i <= 25; i++) 
                if(ch[now][i])
                    {now = ch[now][i]; putchar(i + 'a'); break;}    
        } 
        printf("%dn", len[now] - N / 2);
    }
    return 0;
}