POJ--1936 All in All(水题,暴力即可)

时间:2022-05-11
本文章向大家介绍POJ--1936 All in All(水题,暴力即可),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

All in All Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 30543 Accepted: 12723 Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000. Output

For each test case output “Yes”, if s is a subsequence of t,otherwise output “No”. Sample Input

sequence subsequence person compression VERDI vivaVittorioEmanueleReDiItalia caseDoesMatter CaseDoesMatter Sample Output

Yes No Yes No

#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <stdlib.h>

using namespace std;
#define MAX 100000
char a[MAX+5];
char b[MAX+5];
int main()
{
    int pos;
    bool res;
    while(scanf("%s%s",&a,&b)!=EOF)
    {
        pos=-1;
        res=true;
        int tag;
        int len1=strlen(a);
        int len2=strlen(b);
        for(int i=0;i<len1;i++)
        {
            tag=0;
            for(int j=0;j<len2;j++)
            {
                if(a[i]==b[j])
                {
                    if(j>pos)
                    {
                       tag=1;
                       pos=j;
                       break;
                    }
                }
            }
            if(tag==0)
                res=false;
        }
        if(res==true)
            printf("Yesn");
        else
            printf("Non");
    }
}