POJ--3321 Apple Tree(树状数组+dfs(序列))

时间:2022-05-11
本文章向大家介绍POJ--3321 Apple Tree(树状数组+dfs(序列)),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Apple Tree Time Limit: 2000MS Memory Limit: 65536K Total Submissions: 22613 Accepted: 6875 Description

There is an apple tree outside of kaka’s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won’t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree. The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch. The next line contains an integer M (M ≤ 100,000). The following M lines each contain a message which is either “C x” which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork. or “Q x” which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line. Sample Input

3 1 2 1 3 3 Q 1 C 2 Q 1 Sample Output

3 2

题意: 就是给你一棵树,每一个结点一开始都有一个苹果,然后有两个操作,一个是改变一个结点的值。即有苹果变无苹果,无苹果变有苹果。另一个是求一个结点下面的子树有多少个苹果。这个题目,询问次数100000,显然要用树状数组。属于更新点,求区间和。要知道树状数组无非两种类型,更新点求区间,更新区间求点。此外还要会dfs序列。具体见代码里dfs()函数。dfs序列可以自己百度一下是什么。这道题目是最基础的在树的结构里用树状数组统计

#include <iostream>
#include <string.h>
#include <math.h>

using namespace std;

#define MAX 100010
int head[MAX];
int c[MAX];
int apple[MAX];
int tol;
int n,m;
int tag;
int _right[MAX];
int _left[MAX];
int ans;
int vis[MAX];
struct Node
{
    int value;
    int next;
}edge[MAX*2];
void modify(int x,int y)
{
    edge[tol].value=y;
    edge[tol].next=head[x];
    head[x]=tol++;
}
int lowbit(int x)
{
    return x&(-x);
}
void update(int x,int num)
{
    while(x<=n)
    {
        c[x]+=num;
        x+=lowbit(x);
    }
}
int sum(int x)
{
    int _sum=0;
    while(x>0)
    {
        _sum+=c[x];
        x-=lowbit(x);
    }
    return _sum;
}
void dfs(int x)
{
    vis[x]=1;
    tag++;
    _left[x]=tag;
    int a=head[x];
    while(a!=-1)
    {
      if(vis[edge[a].value]==0)

        dfs(edge[a].value);

        a=edge[a].next;
    }
    _right[x]=tag;
}
void init()
{
    memset(c,0,sizeof(c));
    memset(head,-1,sizeof(head));
    memset(vis,0,sizeof(vis));
}
int main()
{
    int x,y;
    char a;
    int b;
    scanf("%d",&n);
    tol=0;
    tag=0;
    init();
    for(int i=1;i<=n;i++)
    {
        update(i,1);
        apple[i]=1;
    }
       for(int i=0;i<n-1;i++)
    {
        scanf("%d%d",&x,&y);
        modify(x,y);
        modify(y,x);
    }
    dfs(1);
    scanf("%d",&m);
    for(int i=0;i<m;i++)
    {
        getchar();
        scanf("%c",&a);
        scanf("%d",&b);
        if(a=='C')
        {
            if(apple[b]==1)
            {
                update(_left[b],-1);
                apple[b]=0;
            }
            else
            {
                update(_left[b],1);
                apple[b]=1;
            }
        }
        else
        {
            ans=sum(_right[b])-sum(_left[b]-1);
            printf("%dn",ans);
        }


    }
    return 0;
}

随机文章