POJ 2478Farey Sequence

时间:2022-05-08
本文章向大家介绍POJ 2478Farey Sequence,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

escription

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are  F2 = {1/2}  F3 = {1/3, 1/2, 2/3}  F4 = {1/4, 1/3, 1/2, 2/3, 3/4}  F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}  You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn. 

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

POJ Contest,Author:Mathematica@ZSU

std的玄学做法没看懂

给n,求ans[n]。其中ans[n]=ans[n-1]+phi[n],且n的范围比较大,在10的6次以内。则考虑打表解决。  先得到能整除i的最小正整数md[i](一定是个素数),再利用性质3,得到phi[i]

不过我用线性筛水过去啦。

#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define LL long long 
using namespace std;
const LL MAXN=3*1e6+10;
LL prime[MAXN],tot=0,vis[MAXN],phi[MAXN],N;
void GetPhi()
{
    for(LL i=2;i<=N;i++)
    {
        if(!vis[i])
        {
            prime[++tot]=i;
            phi[i]=i-1;
        }
        for(LL j=1;j<=tot&&prime[j]*i<=N;j++)
        {
            vis[ i*prime[j] ] = 1; 
            if(i%prime[j]==0)
            {
                phi[ i*prime[j] ]=phi[i]*prime[j];
                break;
            }
            else phi[ i*prime[j] ]=phi[i]*(prime[j]-1);
        }
    }
    for(LL i=1;i<=N;i++)
        phi[i]=phi[i]+phi[i-1];
}
int main()
{
    N=2*1e6+10;
    GetPhi();
    while(cin>>N&&N!=0)
        printf("%lldn",phi[N]);
    return 0;
}