HDUOJ---A + B Again

时间:2022-05-05
本文章向大家介绍HDUOJ---A + B Again,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

A + B Again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11855    Accepted Submission(s): 5178

Problem Description

There must be many A + B problems in our HDOJ , now a new one is coming. Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too. Easy ? AC it !

Input

The input contains several test cases, please process to the end of the file. Each case consists of two hexadecimal integers A and B in a line seperated by a blank. The length of A and B is less than 15.

Output

For each test case,print the sum of A and B in hexadecimal in one line.

Sample Input

+A -A

+1A 12

1A -9

-1A -12

1A -AA

Sample Output

0

2C

11

-2C

-90

Author

linle

涉及到进制格式问题:X 表示大写的16进制,x表示小写的16进制;

代码

#include<stdio.h>

int main()
{
    _int64 a,b;
    while(scanf("%I64X%I64X",&a,&b)==2)
    {
        if(a+b<0)
        printf("-%I64Xn",-(a+b));
        else
            printf("%I64Xn",a+b);
    }
    return 0;
}