hdu 4009 Transfer water(最小型树图)

时间:2022-05-05
本文章向大家介绍hdu 4009 Transfer water(最小型树图),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others) Total Submission(s): 3995    Accepted Submission(s): 1438

Problem Description

XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.

Input

Multiple cases.  First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).  Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.  Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th household.  If n=X=Y=Z=0, the input ends, and no output for that. 

Output

One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line. 

Sample Input

2 10 20 30 1 3 2 2 4 1 1 2 2 1 2 0 0 0 0

Sample Output

30

Hint

In 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

 ------------ 遇到一个国人发明的算法(algorithm)--------

 下面就开始简单的剖析一下,下面的部分吧!  看图

                   ----------~~~~~~~~~~~~~~~魔板AC~~~~~~~~~~~~~-------------- 

      代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define maxn 1010
#define type int
const int inf = ~0u >> 1;
struct node
{
    int u,v;
    type cost;
    node(){}
    node(int _u,int _v,type _c):u(_u),v(_v),cost(_c){}
}e[maxn * maxn];
int pre[maxn],id[maxn],vis[maxn];
type in[maxn];
type dirmst(int root,int nv,int ne)
{
    type ret = 0;
    while(1)
    {
        //find the smallest in-arc
        fill(in,in + nv,inf);
        for(int i = 0;i < ne;i++)
        {
            int u = e[i].u;
            int v = e[i].v;
            if(e[i].cost < in[v] && u != v)
            {
                pre[v] = u;
                in[v] = e[i].cost;
            }
        }
        for(int i = 0;i < nv;i++)
        {
            if(i == root)
                continue;
            if(in[i] == inf)
                return -1;//there are some nodes other than root with no in-arc connected to it
        }
        //find the dir circle
        int cntnode = 0;
        fill(id,id + nv,-1);
        fill(vis,vis + nv,-1);
        in[root] = 0;
        for(int i = 0;i < nv;i++)
        {
            ret += in[i];
            int v = i;
            while(vis[v] != i && id[v] == -1 && v != root)
            {
                vis[v] = i;
                v = pre[v];
            }
            if(v != root && id[v] == -1)
            {
                for(int u = pre[v]; u != v;u = pre[u])
                    id[u] = cntnode;
                id[v] = cntnode++;
            }
        }
        if(cntnode == 0)
            break;//no circle
        for(int i = 0;i < nv;i++)
            if(id[i] == -1)
                id[i] = cntnode++;
        //compress the nodes
        for(int i = 0;i < ne;i++)
        {
            int v = e[i].v;
            e[i].u = id[e[i].u];
            e[i].v = id[e[i].v];
            if(e[i].u != e[i].v)
                e[i].cost -= in[v];
        }
        nv = cntnode;
        root = id[root];
    }
    return ret;
}
int n,tot,X,Y,Z;
int ab(int x)
{
    return x >= 0?x:-x;
}
struct point
{
    int x,y,z;
    point(){}
    point(int a,int b,int c):x(a),y(b),z(c){}
    point operator - (const point p)
    {
        return point(x - p.x,y - p.y,z - p.z);
    }
    int dis()
    {
        return ab(x) + ab(y) + ab(z);
    }
}p[maxn];
int main()
{
    while(scanf("%d %d %d %d",&n,&X,&Y,&Z) == 4 && (n || X || Y || Z))
    {
        tot = 0;
        for(int i = 1;i <= n;i++)
        {
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            p[i] = point(a,b,c);
            e[tot++] = node(0,i,ab(p[i].z) * X);
        }
        for(int i = 1;i <= n;i++)
        {
            int opt;
            scanf("%d",&opt);
            for(int j = 0;j < opt;j++)
            {
                int a;
                scanf("%d",&a);
                if(a == i)
                    continue;
                int temp = Y * (p[i] - p[a]).dis();
                if(p[i].z < p[a].z)
                    temp += Z;
                e[tot++] = node(i,a,temp);
            }
        }
        int ans = dirmst(0,n + 1,tot);
        if(ans == -1)
            puts("poor XiaoA");
        else
            printf("%dn",ans);
    }
}