HDUOJ---Can you solve this equation?

时间:2022-05-05
本文章向大家介绍HDUOJ---Can you solve this equation?,主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5667    Accepted Submission(s): 2681 http://acm.hdu.edu.cn/showproblem.php?pid=2199

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2 100 -4

Sample Output

1.6152 No solution!

Author

Redow

Recommend

lcy

二分搜索

代码:

#include<iostream>
#include<cstdio>
#define sum(x) ((8*x*x*x*x)+(7*x*x*x)+(2*x*x)+(3*x)+(6))
using namespace std;
int main()
{
    int t;
    double y,mid,left,right;
    cin>>t;
    while(t--)
    {
     scanf("%lf",&y);
     left=0.0,right=100.0;
     if(y>=6.0&&y<=sum(100))
     {
      while(right-left>1e-8)
      {
         mid=(left+right)/2.0;
             if(sum(mid)-y>1e-8)
             right=mid;
         else
             if(y-sum(mid)>1e-8)
                 left=mid;
             else 
                 break;
      } 
         printf("%.4lfn",mid);
     }
     else
         puts("No solution!");
    }
    return 0;
}