hdu----(5045)Contest(数位dp)

时间:2022-05-05
本文章向大家介绍hdu----(5045)Contest(数位dp),主要内容包括其使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Contest

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others) Total Submission(s): 220    Accepted Submission(s): 88

Problem Description

In the ACM International Collegiate Programming Contest, each team consist of three students. And the teams are given 5 hours to solve between 8 and 12 programming problems. On Mars, there is programming contest, too. Each team consist of N students. The teams are given M hours to solve M programming problems. Each team can use only one computer, but they can’t cooperate to solve a problem. At the beginning of the ith hour, they will get the ith programming problem. They must choose a student to solve this problem and others go out to have a rest. The chosen student will spend an hour time to program this problem. At the end of this hour, he must submit his program. This program is then run on test data and can’t modify any more. Now, you have to help a team to find a strategy to maximize the expected number of correctly solved problems. For each problem, each student has a certain probability that correct solve. If the ith student solve the jth problem, the probability of correct solve is Pij . At any time, the different between any two students’ programming time is not more than 1 hour. For example, if there are 3 students and there are 5 problems. The strategy {1,2,3,1,2}, {1,3,2,2,3} or {2,1,3,3,1} are all legal. But {1,1,3,2,3},{3,1,3,1,2} and {1,2,3,1,1} are all illegal. You should find a strategy to maximize the expected number of correctly solved problems, if you have know all probability

Input

The first line of the input is T (1 ≤ T ≤ 20), which stands for the number of test cases you need to solve. The first line of each case contains two integers N ,M (1 ≤ N ≤ 10,1 ≤ M ≤ 1000),denoting the number of students and programming problem, respectively. The next N lines, each lines contains M real numbers between 0 and 1 , the jth number in the ith line is Pij .

Output

For each test case, print a line “Case #t: ”(without quotes, t means the index of the test case) at the beginning. Then a single real number means the maximal expected number of correctly solved problems if this team follow the best strategy, to five digits after the decimal point. Look at the output for sample input for details.

Sample Input

1 2 3 0.6 0.3 0.4 0.3 0.7 0.9

Sample Output

Case #1: 2.20000

Source

2014 ACM/ICPC Asia Regional Shanghai Online

数位DP:

代码:

#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
const int maxn=1050l
double dp[maxn][maxn];
double a[12][maxn];
int main(){
    int cas,n,m;
    scanf("%d",&cas);
    for(int w=1;w<=cas;w++){
        scanf("%d%d",&n,&m);
        for(int i=0;i<=1024;i++){
            for(int j=0;j<=m;j++){
                dp[i][j]=-1;
            }
        }
        dp[0][0]=0.0;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                scanf("%lf",&a[i][j]);
            }
        }
        int tol=(1<<n)-1;
        double ans=0.0;
        for(int j=1;j<=m;j++){
            for(int i=0;i<tol;i++){
                for(int k=1;k<=n;k++){
                    int tt=1<<(k-1);
                    if(dp[i][j-1]<0)continue;

                    if(tt&i)continue;
                    int pos=i|tt;
                    if(pos==tol)pos=0;
                    dp[pos][j]=max(dp[pos][j],dp[i][j-1]+a[k][j]);
                    if(j==m)ans=max(ans,dp[pos][j]);
                }
            }
        }
        printf("Case #%d: %.5lfn",w,ans);
    }
    return 0;
}