PAT (Advanced Level) 1003 Emergency (Dijkstra算法)

时间:2021-08-25
本文章向大家介绍PAT (Advanced Level) 1003 Emergency (Dijkstra算法),主要包括PAT (Advanced Level) 1003 Emergency (Dijkstra算法)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
1003 Emergency (25 分)
 

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (500) - the number of cities (and the cities are numbered from 0 to N1), M - the number of roads, C1 and C2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
 
结尾无空行

Sample Output:

2 4
 
结尾无空行
 
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;

public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        String s = reader.readLine();
        String[] s1 = s.split(" ");
        int N = Integer.parseInt(s1[0]);      //城市数
        int M = Integer.parseInt(s1[1]);      //道路数
        int C1 = Integer.parseInt(s1[2]);     //所在城市
        int C2 = Integer.parseInt(s1[3]);     //目的城市
        int[] dis = new int[N];            //dis[i]表示节点i距离起始点得最短距离
        int[] weight = new int[N];         //weight[i]表示节点i中的急救队数
        int[] w = new int[N];             //w[i]表示从起始点到i能聚集的最大急救队数量
        int[] num = new int[N];           //num[i]表示起始点到i最短路径数
        boolean[] visited = new boolean[N];//标记被访问过的节点
        int[][] edgs = new int[N][N];    //edges[i][j]表示从城市i 到 j的路径长度
        Arrays.fill(dis, Integer.MAX_VALUE);
        Arrays.fill(w, Integer.MIN_VALUE);
        dis[C1] = 0;
        num[C1] = 1;

        String s2 = reader.readLine();
        String[] s3 = s2.split(" ");
        for (int i = 0; i < N; i++) {
            weight[i] = Integer.parseInt(s3[i]);
            Arrays.fill(edgs[i], Integer.MAX_VALUE);
        }

        w[C1] = weight[C1];

        for (int i = 0; i < M; i++){
            String s4 = reader.readLine();
            String[] s5 = s4.split(" ");
            int u = Integer.parseInt(s5[0]);
            int v = Integer.parseInt(s5[1]);
            int len = Integer.parseInt(s5[2]);
            edgs[u][v] = len;
            edgs[v][u] = len;
        }

        for (int i = 0; i < N; i++) {
        //查找离起点距离最小且未被访问过的节点
int u = -1, minDis = Integer.MAX_VALUE; for (int j = 0; j < N; j++) { if (!visited[j] && dis[j] < minDis){ u = j; minDis = dis[j]; } } if (u == -1) break; visited[u] = true; for (int j = 0; j < N; j++) {
//遍历当前访问节点的邻居节点
if (!visited[j] && edgs[u][j] != Integer.MAX_VALUE){ if (dis[u] + edgs[u][j] < dis[j]){ dis[j] = dis[u] + edgs[u][j]; w[j] = w[u] + weight[j]; num[j] = num[u]; }else if (dis[u] + edgs[u][j] == dis[j]){ num[j] = num[u] + num[j]; if (w[j] < w[u] + weight[j]){ w[j] = w[j] = w[u] + weight[j]; } } } } } System.out.println(num[C2] + " " + w[C2]); } }

本文来自博客园,作者:凸云,转载请注明原文链接:https://www.cnblogs.com/jasonXY/p/15186397.html

原文地址:https://www.cnblogs.com/jasonXY/p/15186397.html