Integer Inquiry HDU - 1047 高精度

时间:2020-04-28
本文章向大家介绍Integer Inquiry HDU - 1047 高精度,主要包括Integer Inquiry HDU - 1047 高精度使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)

InputThe input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.
OutputYour program should output the sum of the VeryLongIntegers given in the input.


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
Sample Input

1


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

Sample Output

370370367037037036703703703670
import java.math.*;
import java.util.*;
public class Main {
    public static void main(String[] args)  {
        Scanner sc = new Scanner(System.in);
        int n;
        BigInteger zero=BigInteger.valueOf(0);
        n=sc.nextInt();
        while(n-->0)
        {
            BigInteger s=BigInteger.valueOf(0);
            BigInteger a[]=new BigInteger[1010];
            for(int i=0;;i++)
            {
            a[i]=cin.nextBigInteger();
            if(a[i].equals(zero))
                break;
            else s=s.add(a[i]);
            }
            System.out.println(s);
            if(n!=0)
                System.out.println("");
        }
 
    }
}

原文地址:https://www.cnblogs.com/xxxsans/p/12795392.html