【floyd+矩阵乘法】POJ 3613 Cow Relays

时间:2020-04-28
本文章向大家介绍【floyd+矩阵乘法】POJ 3613 Cow Relays,主要包括【floyd+矩阵乘法】POJ 3613 Cow Relays使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Description

For their physical fitness program, N (2 ≤ N ≤ 1,000,000) cows have decided to run a relay race using the T (2 ≤ T ≤ 100) cow trails throughout the pasture.

Each trail connects two different intersections (1 ≤ I1i ≤ 1,000; 1 ≤ I2i ≤ 1,000), each of which is the termination for at least two trails. The cows know the lengthi of each trail (1 ≤ lengthi ≤ 1,000), the two intersections the trail connects, and they know that no two intersections are directly connected by two different trails. The trails form a structure known mathematically as a graph.

To run the relay, the N cows position themselves at various intersections (some intersections might have more than one cow). They must position themselves properly so that they can hand off the baton cow-by-cow and end up at the proper finishing place.

Write a program to help position the cows. Find the shortest path that connects the starting intersection (S) and the ending intersection (E) and traverses exactly N cow trails.

Input

  • Line 1: Four space-separated integers: N, T, S, and E
  • Lines 2..T+1: Line i+1 describes trail i with three space-separated integers: lengthi , I1i , and I2i

Output

  • Line 1: A single integer that is the shortest distance from intersection S to intersection E that traverses exactly N cow trails.

Sample Input

2 6 6 4
11 4 6
4 4 8
8 4 9
6 6 8
2 6 9
3 8 9

Sample Output

10

分析

  • 题意:给定一个T(2 <= T <= 100)条边的无向图,求S到E恰好经过N(2 <= N <= 1000000)条边的最短路。
  • 分析:大致思路就是floyd+矩阵乘法。我们令C[S][E]表示S点到E点正好经过N条边的路径数。
  • 接下来用Floyd每次使用一个中间点k去更新S,E之间的距离,那么更新成功表示S,E之间恰有一个点k时的最短路。我们做n次这样的操作就能够得出结果了。
  • 我们用c[S][E]=max(c[S][E],a[S][k]+a[k][E])来进行路径长度更新。第二次将c[S][E]拷贝回到a[S][E]当中,并将c[S][E]重新置为inf,再做一次,则是在原来的基础上在S,E之间再用一个点k来松弛,这时候S,E之间实际上已经是两个点了,之后重复这么做就好了.

代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf = 0x7f7f7f7f;
const int maxn = 1010;
int K,M,S,T;
int v[maxn],cnt,map[maxn][maxn],used[maxn];
int ans[maxn][maxn],dis[maxn][maxn],tmp[maxn][maxn];
void floyd(int c[][maxn],int a[][maxn],int b[maxn][maxn]){
       int i,j,k;
       for(k=0;k<cnt;k++){
              for(i=0;i<cnt;i++){
                     for(j=0;j<cnt;j++){
                            if(c[v[i]][v[j]]>a[v[i]][v[k]]+b[v[k]][v[j]])
                                   c[v[i]][v[j]]=a[v[i]][v[k]]+b[v[k]][v[j]];
                     }
              }
       }
}
void copy(int a[][maxn],int b[][maxn]){
       int i,j;
       for(i=0;i<cnt;i++){
              for(j=0;j<cnt;j++){
                     a[v[i]][v[j]]=b[v[i]][v[j]];
                     b[v[i]][v[j]]=inf;
              }
       }
}
void solve(int k){
       while(k){
              if(k%2){
                     floyd(dis,ans,map);
                     copy(ans,dis);
              }
              floyd(tmp,map,map);
              copy(map,tmp); 
              k=k/2;
       }
}
int main(){
       int i,j;
       int x,y,val;
       while(scanf("%d%d%d%d",&K,&M,&S,&T)==4){
                for(i=0;i<=1001;i++){
                    for(j=0;j<=1001;j++){
                        map[i][j]=inf;
                        ans[i][j]=inf;
                        tmp[i][j]=inf;
                        dis[i][j]=inf;
                    }
                    ans[i][i]=0;
                }
                memset(used,0,sizeof(used));
                cnt=0;
                for(i=0;i<M;i++){
                    scanf("%d%d%d",&val,&x,&y);
                    if(map[x][y]>val){
                            map[x][y]=val;
                            map[y][x]=map[x][y];
                    }
                    if(!used[x]){
                            used[x]=1;
                            v[cnt++]=x;
                    }
                    if(!used[y]){
                            used[y]=1;
                            v[cnt++]=y;
                    }
            }
            solve(K);
            printf("%d\n",ans[S][T]);
       }
       return 0;
}

原文地址:https://www.cnblogs.com/Vocanda/p/12794502.html