1007 Maximum Subsequence Sum

时间:2020-03-26
本文章向大家介绍1007 Maximum Subsequence Sum,主要包括1007 Maximum Subsequence Sum使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Given a sequence of K integers { N1​​, N2​​, ..., NK​​ }. A continuous subsequence is defined to be { Ni​​, Ni+1​​, ..., Nj​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
 

Sample Output:

10 1 4

题意:

最大子序列和

Code:

#include<iostream>
#include<algorithm>
#include<vector>

using namespace std;

int main() {
    int n;
    cin >> n;

    vector<int> arr;
    for (int i = 0; i < n; ++i) {
        int num;
        cin >> num;
        arr.push_back(num);
    }

    int sum = -1, left = 0, right = n - 1;
    int temp = 0, tempLeft = 0;
    for (int i = 0; i < n; ++i) {
        temp += arr[i];
        if (temp < 0) {
            temp = 0;
            tempLeft = i + 1;
        } else if (temp > sum) {
            sum = temp;
            left = tempLeft;
            right = i;
        }
    }

    if (sum < 0) sum = 0;
    cout << sum << " " << arr[left] << " " << arr[right];

    return 0;
}

  

参考:

https://www.liuchuo.net/archives/2122

原文地址:https://www.cnblogs.com/ruruozhenhao/p/12575313.html