1014 Waiting in Line (30分)

时间:2020-01-09
本文章向大家介绍1014 Waiting in Line (30分),主要包括1014 Waiting in Line (30分)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

1014 Waiting in Line (30分)

 

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customeri​​ will take Ti​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1​​ is served at window1​​ while customer2​​ is served at window2​​. Customer3​​ will wait in front of window1​​ and customer4​​ will wait in front of window2​​. Customer5​​ will wait behind the yellow line.

At 08:01, customer1​​ is done and customer5​​ enters the line in front of window1​​ since that line seems shorter now. Customer2​​ will leave at 08:02, customer4​​ at 08:06, customer3​​ at 08:07, and finally customer5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (20, number of windows), M (10, the maximum capacity of each line inside the yellow line), K (1000, number of customers), and Q (1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
 

Sample Output:

08:07
08:06
08:10
17:00
Sorry


题意:

银行的上班时间为上午8:00到17:00(540分钟),银行有N个窗口,每个窗口前可以有M个位置排队。

银行来了K个客户,依次给出k个客户办理业务需要的时间tim[i],有q次询问,

每次询问第x个人的结束时间,若第x个人没有办理业务就输出Sorry

客户选择最短的队伍排,根据每个客户的序号和服务时间来确定最后客户离开银行的时间。

题解:

  https://blog.csdn.net/Apie_CZX/article/details/45537627

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
#include<stack>
#include<algorithm>
#include<map>
#include<string.h>
#include<string>
#include<queue>
#define MAX 1000000
#define ll long long
using namespace std;
int tim[1005],vis[1005];//vis标记每一个顾客的结束时间
queue<int>p[25];
int main()
{
    int n,m,k,q;
    cin>>n>>m>>k>>q;
    for(int i=1;i<=k;i++)
        cin>>tim[i];

    int sum=0,cnt=1;
    for(int t=0;t<540;t++)//只处理在上班时间范围内的顾客
    {
        while(sum<n*m&&cnt<=k)//先让所有人先进去(总人数为小于黄线区域内可以容纳的人数)
        {
            int id=0;//队伍最短的窗口编号
            for(int i=0;i<n;i++)
            {
                if(p[i].size()<p[id].size())//有更短的窗口
                    id=i;
                if(p[id].size()==0)//该窗口没人
                    vis[cnt]=t+tim[cnt];//标记第cnt个人的结束时间
                if(p[id].size()<m&&cnt<=k)//准备处理下一个人
                {
                    p[id].push(cnt);
                    cnt++;
                    sum++;
                }
            }
        }

        for(int i=0;i<n;i++)//n个窗口
        {
            for(int j=0;j<p[i].size();j++)
            {
                if(t==vis[p[i].front()])//第i个窗口的结束时间恰好是当前时间t
                {
                    p[i].pop();
                    sum--;

                    if(!p[i].empty())//记录该窗口下一个顾客的结束时间
                    {
                        int temp=p[i].front();
                        vis[temp]=t+tim[temp];
                    }
                }
            }
        }
    }
    for(int i=0;i<q;i++)
    {
        int x;
        cin>>x;
        if(vis[x]==0)
            cout<<"Sorry"<<endl;
        else
            printf("%02d:%02d\n",8+vis[x]/60,vis[x]%60);
    }
    return 0;
}

原文地址:https://www.cnblogs.com/-citywall123/p/12172488.html