PAT 甲级 1079 Total Sales of Supply Chain (25 分)(简单,不建树,bfs即可)

时间:2019-12-04
本文章向大家介绍PAT 甲级 1079 Total Sales of Supply Chain (25 分)(简单,不建树,bfs即可),主要包括PAT 甲级 1079 Total Sales of Supply Chain (25 分)(简单,不建树,bfs即可)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
1079 Total Sales of Supply Chain (25 分)
 

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤), the total number of the members in the supply chain (and hence their ID's are numbered from 0 to N1, and the root supplier's ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki​​ ID[1] ID[2] ... ID[Ki​​]

where in the i-th line, Ki​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID's of these distributors or retailers. Kj​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题意:

在一个供应链中,有批发商,中间商,零售商,只有零售商会对普通顾客出售商品,商品的原价是固定,每经过一级经销商,商品的价格会增加t%,题目会给出美国零售商的货物数量,要求你求出所有在售商品的价值总和,在输入中先给出结点数量n,然后在接下来的n行中,依次在每一行给出0~n-1号结点的子节点数量,子节点编号,如果子节点数量为0,那么说明该结点是叶节点,本行第二个数是零售商的货物数量
————————————————
版权声明:本文为CSDN博主「热心市民小黎」的原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接及本声明。
原文链接:https://blog.csdn.net/qq_33657357/article/details/8234534

题解:

先用结构体,结构体里out向量存储下面到哪些点

bfs,根据入度为0,找到根节点,借用队列,一层层向外计算,当前节点的 val = 上一个的val * (1+r/100)

AC代码:

#include<bits/stdc++.h>
using namespace std;
int in[100005];
struct node{
    double val;
    vector<int>out;
}a[100005];
queue<int>q;
int xiao[100005];
int n;
double p,r;
double s=0;
int main(){
    cin>>n>>p>>r;
    memset(in,0,sizeof(in));
    for(int i=0;i<n;i++){
        int k;
        cin>>k;
        if(k==0) cin>>xiao[i];
        for(int j=1;j<=k;j++){
            int x;
            cin>>x;
            a[i].out.push_back(x);
            in[x]++;
        }
    }
    int root=-1;
    for(int i=0;i<n;i++){
        if(in[i]==0){
            root=i;
            break;
        }
    }
    a[root].val=p;
    q.push(root);
    while(!q.empty()){
        int x=q.front();
        q.pop();
        if(a[x].out.size()==0){
            s+=xiao[x]*a[x].val;
        }else{
            double u=a[x].val*(1+r/100);
            for(int i=0;i<a[x].out.size();i++){
                int y=a[x].out.at(i);
                a[y].val=u;
                q.push(y);
            }
        }
    }
    printf("%.1f",s);
    return 0;
}

原文地址:https://www.cnblogs.com/caiyishuai/p/11983057.html