(贪心+并查集综合)[POJ1456] Supermarket

时间:2019-10-29
本文章向大家介绍(贪心+并查集综合)[POJ1456] Supermarket,主要包括(贪心+并查集综合)[POJ1456] Supermarket使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 20725 Accepted: 9192

Description

A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8 2
   5 20  50 10

Sample Output

80
185

Hint

The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.

Source

Southeastern Europe 2003

解题思路

代码样例

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <set>
#include <string>
#include <map>
#include <vector>
#include <queue>
#include <stack>
using namespace std;
typedef long long ll;

const int maxn = 10000 + 5;
pair<ll, ll> list[maxn];
ll pa[maxn];

bool cmp(pair<ll, ll> a, pair<ll, ll> b)
{
    return a.first > b.first;
}

ll find_root(ll x)
{
    int x_root = x;
    while (pa[x_root] != x_root)
        x_root = pa[x_root];
    int i = x, j;
    while (pa[i] != x_root)
    {
        j = pa[i];
        pa[i] = x_root;
        i = j;
    }
    return x_root;
}

int main()
{
    int t;
    while (cin >> t)
    {
        for (int i = 1; i <= t; i++)
            cin >> list[i].first >> list[i].second;
        for (int i = 1; i < maxn; i++)
            pa[i] = i;
        sort(list + 1, list + 1 + t, cmp);
        int ans = 0;
        for (int i = 1; i <= t; i++)
        {
            int root_ = find_root(list[i].second);
            if (root_ == 0)
                continue;
            else
            {
                pa[root_] = find_root(root_ - 1);
                ans += list[i].first;
            }
        }
        cout << ans << endl;
    }
    //system("pause");
    return 0;
}

原文地址:https://www.cnblogs.com/cafu-chino/p/11759434.html