poj-2234 Matches Game Nim

时间:2019-10-10
本文章向大家介绍poj-2234 Matches Game Nim,主要包括poj-2234 Matches Game Nim使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
Matches Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13264   Accepted: 7712

Description

Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.

Input

The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10000000. These M integers represent the number of matches in each pile.

Output

For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".

Sample Input

2 45 45
3 3 6 9

Sample Output

No
Yes

Source

POJ Monthly,readchild
 
AC Code:
#include<cstdio>
using namespace std;
int main()
{
    int n;
    while(~scanf("%d",&n)) {
        int ans;
        scanf("%d",&ans);
        n--;
        for(int i=0;i<n;i++) {
            int x;
            scanf("%d",&x);
            ans^=x;
        }
        printf("%s\n",ans?"Yes":"No");
    }
} 

原文地址:https://www.cnblogs.com/cautx/p/11651147.html