快排 PAT 1101

时间:2019-09-19
本文章向大家介绍快排 PAT 1101,主要包括快排 PAT 1101使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
1101 Quick Sort (25 分)
 

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then the next line contains N distinct positive integers no larger than 1. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5




#include <bits/stdc++.h>
using namespace std;
#define N 100010
int  a[N],n;
int vis[N];
vector<int>ve;
//有多少个数它左边比它小,右边比它大 
int main()
{
    scanf("%d",&n);
    for(int  i=1;i<=n;i++) scanf("%d",&a[i]);
    for(int i =1;i<=n;i++) vis[i] = 1;
    int maxx = a[1];
    //因为是N个不同的数,那么从左到右应该是递增
    //只要不满足这个条件,就一定不是,逆序时同理 
    for(int i =1;i<=n;i++){
        if(a[i]<maxx) vis[i] = 0;
        else{
            maxx = a[i];
        }
    }
    int minn  =a[n];
    for(int  i=n;i>=1;i-- ){
        if(a[i]>minn) vis[i] = 0;
        else {
            minn  =a[i];
        }
    }
    int cnt  = 0;
    for(int i =1;i<=n;i++){
        if(vis[i]==1) 
        {    
         cnt++;
        ve.push_back(a[i])    ;
          } 
    }
    if(cnt==0) printf("0\n\n");
    else{
        printf("%d\n",cnt);
        sort(ve.begin(),ve.end());
        for(int  i =0;i<ve.size();i++){
            if(i==0) printf("%d",ve[i]);
            else{
                printf(" %d",ve[i]);
            }
        }
    }
     return 0;
}
 

原文地址:https://www.cnblogs.com/tingtin/p/11549874.html