poj 3352

时间:2019-08-31
本文章向大家介绍poj 3352,主要包括poj 3352使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

It's almost summer time, and that means that it's almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3

Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

边的双联通 模板,缩点后用度数为一的点个数+1除2就是答案
#include<iostream>
#include<cstring>
using namespace std;

const int maxn = 5005;

int n,m,size,head[maxn],low[maxn],fa[maxn],dfn[maxn],ncnt,cnt,hash[maxn],tim,px[maxn],py[maxn],d[maxn];

struct edge{
    int v,nex;
}e[maxn<<1];

void adde(int u,int v){
    e[size].v=v;e[size].nex=head[u];head[u]=size++;
}

int find(int x){
    return x==fa[x]?x:fa[x]=find(fa[x]);
}

void tarjan(int u,int par){
    low[u]=dfn[u]=++tim;
    for(int i=head[u];~i;i=e[i].nex){
        int v=e[i].v;
        if(!dfn[v]){
            tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(dfn[u]<low[v]) px[++cnt]=u,py[cnt]=v;
            else {
                int x=find(u),y=find(v);
                if(x!=y) fa[x]=y;
            }
        }else if(v!=par) low[u]=min(low[u],dfn[v]);
    }
}

int main(){
    scanf("%d%d",&n,&m);
        memset(head,-1,sizeof(head));tim=0;
        memset(dfn,0,sizeof(dfn));
        for(int i=1;i<=m;i++){
            int u,v;scanf("%d%d",&u,&v);
            adde(u,v);adde(v,u);
        }
        for(int i=1;i<=n;i++) fa[i]=i;cnt=0;
        tarjan(1,-1);
        memset(hash,-1,sizeof(hash));ncnt=0;
        for(int i=1;i<=n;i++){
            int x=find(i);
            if(hash[x]==-1) hash[x]=++ncnt;
        }
        for(int i=1;i<=cnt;i++){
            d[hash[find(px[i])]]++;d[hash[find(py[i])]]++;
        }
        int ans=0;
        for(int i=1;i<=ncnt;i++){
            if(d[i]==1) ans++;
        } 
        printf("%d\n",(ans+1)/2);
} 
View Code

原文地址:https://www.cnblogs.com/plysc/p/11440230.html