交换实验2

时间:2019-08-24
本文章向大家介绍交换实验2,主要包括交换实验2使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

1. 在SW1、SW2、SW3和SW4上创建VLAN12、13、24、112、103、212、312、334、305、401和402

根据需求配置相应VLAN,并使用display vlan summary命令查看VLAN的概要信息。

以SW1为例:

vlan batch 12 to 13 24 103 to 104 112 212 305 312 334 401 to 40

2. 将SW1的G0/0/1和G0/0/2划入VLAN112,将G0/0/3划入VLAN103

完成该需求之后,我们通过命令display vlan查看VLAN对应接口信息

interface GigabitEthernet0/0/1
port link-type access
port default vlan 112
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 112
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 103

3. 将SW2的G0/0/1和G0/0/2划入VLAN212

完成该需求后,我们通过命令display vlan来查看基于端口划分VLAN的信息。

4. 将SW3的G0/0/1和SW3的G0/0/2划入VLAN312,将SW3的G0/0/3和G0/0/4划入VLAN334,将SW3的G0/0/5划入VLAN305

完成该需求之后,我们通过命令display vlan查看基于端口划分VLAN的信息

5. 在SW4上,将MAC地址为5489-98CF-447F、IP地址为4.1.1.1的PC41划入VLAN401,MAC地址为5489-98CF-G17D、IP地址为4.2.2.2划入VLAN402

完成该需求后,我们通过命令display policy-vlan all来查看SW4上划分的VLAN信息

interface GigabitEthernet0/0/1
port hybrid pvid vlan 401
port hybrid untagged vlan 401
#
interface GigabitEthernet0/0/2
port hybrid pvid vlan 402
port hybrid untagged vlan 402

vlan 401
policy-vlan mac-address 5489-9897-08e5 ip 4.1.1.1
vlan 402
policy-vlan mac-address 5489-98a4-2f56 ip 4.2.2.2

在实现需求的过程中,注意VLAN划分主要分为基于端口、基于MAC地址、基于IP地址、基于协议和基于策略。通过需求描述推断出根据哪种方法来划分VLAN。另外在划分VLAN时,需要特别注意端口属性。

此处也可以考虑通过以下命令对结果进行验证:

display vlan

6. 在SW1上,通过合适的技术实现VLAN112和VLAN103之间的二层隔离、三层转发功能。另外可以在交换机上创建VLAN104,IP地址为1.0.0.254/24

提示:使用supervlan

二层隔离的VLAN之间经过三层接口互通需要启用VLAN间的

Proxy ARP。

完成该需求后,我们通过命令display sub-vlan/ display super-vlan查看

vlan 104
aggregate-vlan
access-vlan 103 112

interface Vlanif104
ip address 1.0.0.254 255.255.255.0
arp-proxy inter-sub-vlan-proxy enable

将接口放到vlan中

7. 在SW2上实现VLAN212内PC21和PC22二层隔离三层互通。另外可以在交换机上创建VLAN212,IP地址为2.0.0.254/24 

提示:使用port-isolate

二层隔离端口之间经过三层接口互通需要启用VLAN内的Proxy ARP。

完成该需求后,我们通过命令display port-isolate来查看验证是否配置成功

进接口:

port-isolate enable

interface Vlanif212
ip address 2.0.0.254 255.255.255.0
arp-proxy inner-sub-vlan-proxy enable

8. 在SW3上实现VLAN312、VLAN334均可以和VLAN305通信,但是VLAN312和VLAN334之间不能通信,VLAN312内的PC31和PC32可以互通,另外VLAN334内PC33和PC34不能互访

使用mux-vlan

vlan 305
mux-vlan
subordinate separate 334
subordinate group 312

#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 312
port mux-vlan enable
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 312
port mux-vlan enable
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 334
port mux-vlan enable
#
interface GigabitEthernet0/0/4
port link-type access
port default vlan 334
port mux-vlan enable
#
interface GigabitEthernet0/0/5
port link-type access
port default vlan 305
port mux-vlan enable

interface GigabitEthernet0/0/10

port link-type access
port default vlan 305
port mux-vlan enable

9. 在SW4上实现VLAN401和VLAN402需要实现互通,其中VLANif401的IP地址为4.1.1.254/24,VLANif402的IP地址为4.2.2.254/24

interface Vlanif401
ip address 4.1.1.254 255.255.255.0
#
interface Vlanif402
ip address 4.2.2.254 255.255.255.0

10. 实现VLAN312、VLAN334和VLAN305中的PC与SW4的VLANif305地址的互通

11. 根据网络拓扑创建相应的VLANif并配置合适的端口属性,允许VLAN12、13、24、112、103、212、312、334、305、401和402通过

完成该需求后,我们通过命令display vlan和display ip interface查看VLAN信息和IP信息

SW1:

interface GigabitEthernet0/0/10
port link-type trunk
port trunk allow-pass vlan 12 to 13 24 103 112 212 305 312 334 401 to 402
#
interface GigabitEthernet0/0/11
port link-type trunk
port trunk allow-pass vlan 12 to 13 24 103 112 212 305 312 334 401 to 402

SW2:

interface GigabitEthernet0/0/10
port link-type trunk
port trunk allow-pass vlan 12 to 13 24 103 112 212 305 312 334 401 to 402
#
interface GigabitEthernet0/0/11
port link-type trunk
port trunk allow-pass vlan 12 to 13 24 103 112 212 305 312 334 401 to 402

SW3:

interface GigabitEthernet0/0/11
port link-type trunk
port trunk allow-pass vlan 12 to 13 24 30 103 112 212 305 312 334 401 to 402

SW4:

interface GigabitEthernet0/0/11
port link-type trunk
port trunk allow-pass vlan 12 to 13 24 103 112 212 305 312 334 401 to 402

12. SW1、SW2、SW3和SW4上运行RIPv2并禁用汇总。在SW1上将VLANif12、VLANif13和VLANif104通告进RIPv2;在SW2上将VLANif12、VLANif24和VLANif212通告进RIPv2;在SW3上将VLANif13通告进RIP;在SW4上将VLANif24、VLANif305、VLANif401、VLANif402通告进RIPv2。最终能够实现不同网段的互通(将sw3上的pc机配网关3.0.0.254)

完成该需求后,我们通过命令display ip routing-table查看路由信息

SW1:

rip 1
undo summary
version 2
network 12.0.0.0
network 13.0.0.0
network 1.0.0.0

SW2:

rip 1
undo summary
version 2
network 12.0.0.0
network 24.0.0.0
network 2.0.0.0

SW3:

rip 1
undo summary
version 2
network 13.0.0.0

SW4:

rip 1
undo summary
version 2
network 24.0.0.0
network 3.0.0.0
network 4.0.0.0

原文地址:https://www.cnblogs.com/TiAmoLJ/p/11405941.html