POJ 1306 暴力求组合数

时间:2019-08-24
本文章向大家介绍POJ 1306 暴力求组合数,主要包括POJ 1306 暴力求组合数使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
Combinations
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11049   Accepted: 5013

Description

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following:
GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N
Compute the EXACT value of: C = N! / (N-M)!M!
You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is:
93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000

Input

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read.

Output

The output from this program should be in the form:
N things taken M at a time is C exactly.

Sample Input

100  6
20  5
18  6
0  0

Sample Output

100 things taken 6 at a time is 1192052400 exactly.
20 things taken 5 at a time is 15504 exactly.
18 things taken 6 at a time is 18564 exactly.

题意:

输入n,k,然后算一下组合数就行了,关键:“You may assume that the final value of C will fit in a 32-bit”,所以还是很无聊的一题。

AC code:

#include<cstdio>
using namespace std;
typedef long long ll;
ll c[110][110];
void prepare()
{
    for(int i=0;i<=110;i++)    c[i][0]=1;
    for(int i=1;i<=110;i++)
        for(int j=1;j<=110;j++)
            c[i][j]=c[i-1][j]+c[i-1][j-1];
}
int main()
{
    //freopen("input.txt","r",stdin);
    prepare();
    ll n,k;
    while(~scanf("%lld%lld",&n,&k)&&n)
    {
        printf("%lld things taken %lld at a time is %lld exactly.\n",n,k,c[n][k]);
    }
    return 0;
}
View Code

原文地址:https://www.cnblogs.com/cautx/p/11404467.html