PAT 1012 The Best Rank 排序

时间:2019-08-21
本文章向大家介绍PAT 1012 The Best Rank 排序,主要包括PAT 1012 The Best Rank 排序使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C – C Programming Language, M – Mathematics (Calculus or Linear Algebra), and E – English. At the mean time, we encourage students by emphasizing on(强调) their best ranks — that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.
For example, The grades of C, M, E and A – Average of 4 students are given as the following:
Student ID C M E A
310101 98 85 88 90
310102 70 95 88 84
310103 82 87 94 88
310104 91 91 91 91
Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.
The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.
If a student is not on the grading list, simply output “N/A”.

Sample Input

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output

1 C
1 M
1 E
1 A
3 A
N/A

题目意思:已知n个学生的3门科目的分数,平均分可以通过3门成绩计算得到,这样就会有4种排名C(C Programming Language)、M(Mathematics)、E(English)、A(Average),对于K次查询,给一个学生的ID,输出该学生在4种排名中最好的排名和排名方式,如果在多种排名方式中的排名相同,那么按照A>C>M>E的顺序输出,如果ID不存在

输出N/A。

解题思路:这个题已经有点成绩查询系统的意思了,核心是排序,需要注意的一点是排名并列应该是1、1、3、4、5而不是1、1、2、3、4。

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
struct student{
    int id;
    int best;
    int score[4];
    int ranks[4];
}stu[2010];
int vis[1000010];
int flag;
int cmp(student A,student B)
{
    return A.score[flag]>B.score[flag];
}

int main()
{
    int n,m,id,i,j,best,temp;
    char c[5]={'A','C','M','E'};
    scanf("%d%d",&n,&m);
    for(i=0;i<n;i++)
    {
        scanf("%d%d%d%d",&stu[i].id,&stu[i].score[1],&stu[i].score[2],&stu[i].score[3]);
        stu[i].score[0]=(stu[i].score[1]+stu[i].score[2]+stu[i].score[3])/3.0;//平均分
    }
    for(flag=0;flag<=3;flag++)//确定排名,保存在不同flag下的排名
    {
        sort(stu,stu+n,cmp);
        stu[0].ranks[flag]=1;
        for(i=1;i<n;i++)
        {
            stu[i].ranks[flag]=i+1;
            if(stu[i].score[flag]==stu[i-1].score[flag])//成绩相同。排名将会并列
            {
                stu[i].ranks[flag]=stu[i-1].ranks[flag];
            }
        }
    }
    for(i=0;i<n;i++)//确定每个人在4种排名方式下的最好排名
    {
        vis[stu[i].id]=i+1;//序号
        stu[i].best=0;
        int mins=stu[i].ranks[0];
        for(j=1;j<=3;j++)
        {
            if(stu[i].ranks[j]<mins)
            {
                mins=stu[i].ranks[j];
                stu[i].best=j;
            }
        }
    }
    for(i=0;i<m;i++)
    {
        scanf("%d",&id);
        temp=vis[id];
        if(temp)
        {
            best=stu[temp-1].best;
            printf("%d %c\n", stu[temp-1].ranks[best], c[best]);
        }
        else
        {
            printf("N/A\n");
        }
    }
    return 0;
}

原文地址:https://www.cnblogs.com/wkfvawl/p/11388397.html