【POJ】1733Parity game(并差集转化)

时间:2019-02-20
本文章向大家介绍【POJ】1733Parity game(并差集转化),主要包括【POJ】1733Parity game(并差集转化)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13593   Accepted: 5225

Description

Now and then you play the following game with your friend. Your friend writes down a sequence consisting of zeroes and ones. You choose a continuous subsequence (for example the subsequence from the third to the fifth digit inclusively) and ask him, whether this subsequence contains even or odd number of ones. Your friend answers your question and you can ask him about another subsequence and so on. Your task is to guess the entire sequence of numbers. 

You suspect some of your friend's answers may not be correct and you want to convict him of falsehood. Thus you have decided to write a program to help you in this matter. The program will receive a series of your questions together with the answers you have received from your friend. The aim of this program is to find the first answer which is provably wrong, i.e. that there exists a sequence satisfying answers to all the previous questions, but no such sequence satisfies this answer.

Input

The first line of input contains one number, which is the length of the sequence of zeroes and ones. This length is less or equal to 1000000000. In the second line, there is one positive integer which is the number of questions asked and answers to them. The number of questions and answers is less or equal to 5000. The remaining lines specify questions and answers. Each line contains one question and the answer to this question: two integers (the position of the first and last digit in the chosen subsequence) and one word which is either `even' or `odd' (the answer, i.e. the parity of the number of ones in the chosen subsequence, where `even' means an even number of ones and `odd' means an odd number).

Output

There is only one line in output containing one integer X. Number X says that there exists a sequence of zeroes and ones satisfying first X parity conditions, but there exists none satisfying X+1 conditions. If there exists a sequence of zeroes and ones satisfying all the given conditions, then number X should be the number of all the questions asked.

Sample Input

10
5
1 2 even
3 4 odd
5 6 even
1 6 even
7 10 odd

Sample Output

3

Source

CEOI 1999

题目大意:现在给你一个M长的串,串中只有0和1。然后n次询问及回答,在第x至第y位中1的个数是奇数或是偶数。问从哪一次开始,下一次的回答与之前的是矛盾的。也就是找第一次中途的句子,其中 e为偶数 o为奇数

思路:这个题目的话,是将某个条件,也就是题中给出的回答奇数和偶数分到两个森林中去,奇数的和偶数的,

就是将其分为两块区域,1~n 和n+1~2n,分别来判断之间是奇数还是偶数。如果是偶数,那么(x,y)在一个集合,(x+maxn,y+maxn)在一个集合,在放进去前先需要判断(x,y+maxn)(x+maxn,y)在不在一个集合,如果在,就说明这条开始错了。同理如果是奇数,那么(x+maxn,y)在一个集合(x,y+maxn)在一个集合,也需要先判断(x,y)(x+maxn,y+maxn)在不在一个集合。

代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#define ll long long
using namespace std;
const int maxn=50000+5;
const int maxm=1e5+10;
int F[maxm];
ll m;
int n;
int findset(int x)
{
    if(F[x]==-1) return x;
    return F[x]=findset(F[x]);
}
void bind(int x,int y)
{
    int fx=findset(x);
    int fy=findset(y);
    if(fx!=fy)
    {
        F[fy]=fx;
    }
}
bool same(int x,int y)
{
    return findset(x)==findset(y);
}
int main()
{
    memset(F,-1,sizeof(F));
    scanf("%lld",&m);
    int n;scanf("%d",&n);
    bool flag=false;
    int ans=-1;
    int x,y;
    char s[10];
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&x,&y);
        getchar();
        scanf("%s",s);
        if(flag==false)
        {//cout<<1<<endl;
            x=(x-1)%maxn,y=y%maxn;
            if(s[0]=='e')
            {
                if(same(x,y+maxn)||same(x+maxn,y))
                {
                    ans=i;flag=true;
                }
                else
                {
                    bind(x,y);bind(x+maxn,y+maxn);
                }
            }
            else
            {
                if(same(x,y)||same(x+maxn,y+maxn))
                {
                    ans=i;flag=true;
                }
                else
                {
                    bind(x+maxn,y);bind(x,y+maxn);
                }
            }
        }
    }
    if(ans==-1)
            printf("%d\n",n);
        else
            printf("%d\n",ans);
}