PAT (Advanced Level) 1118 Birds in Forest (25 分)

时间:2019-02-19
本文章向大家介绍PAT (Advanced Level) 1118 Birds in Forest (25 分),主要包括PAT (Advanced Level) 1118 Birds in Forest (25 分)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

1118 Birds in Forest (25 分)

Some scientists took pictures of thousands of birds in a forest. Assume that all the birds appear in the same picture belong to the same tree. You are supposed to help the scientists to count the maximum number of trees in the forest, and for any pair of birds, tell if they are on the same tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤10​4​​) which is the number of pictures. Then N lines follow, each describes a picture in the format:

K B​1​​ B​2​​ ... B​K​​

where K is the number of birds in this picture, and B​i​​’s are the indices of birds. It is guaranteed that the birds in all the pictures are numbered continuously from 1 to some number that is no more than 10​4​​.
After the pictures there is a positive number Q (≤10​4​​) which is the number of queries. Then Q lines follow, each contains the indices of two birds.

Output Specification:

For each test case, first output in a line the maximum possible number of trees and the number of birds. Then for each query, print in a line Yes if the two birds belong to the same tree, or No if not.

Sample Input:

4
3 10 1 2
2 3 4
4 1 5 7 8
3 9 6 4
2
10 5
3 7

Sample Output:

2 10
Yes
No

Code:

#include <iostream>
#include <cstdio>
#include <vector>

using namespace std;

vector<int> father;

int findFather(int x)
{
	int a = x;
	while(x != father[x])
		x = father[x];
	while(a != father[a])
	{
		int z = a;
		a = father[a];
		father[z] = x;
	}
	return x;
}

void Union(int a, int b)
{
	int fa = findFather(a);
	int fb = findFather(b);
	if (fa != fb)
		father[fb] = fa;
}

int main()
{
	int pn;
	scanf("%d", &pn);
	father.resize(10001);
	for (int i=0; i<father.size(); i++)
		father[i] = i;
	int maxID = 1;
	for (int i=0; i<pn; i++)
	{
		int tn;scanf("%d", &tn);
		int id;scanf("%d", &id);
		if (id > maxID) maxID = id;	
		for (int j=1; j<tn; j++)
		{
			int temp; scanf("%d", &temp);
			if (temp > maxID) maxID = temp;
			Union(findFather(id), findFather(temp));
		}
	}
	int cnt = 0;
	for (int i=1; i<=maxID; i++)
		if(i == father[i]) cnt++;
	printf("%d %d\n", cnt, maxID);
	int qn; scanf("%d", &qn);
	for (int i=0; i<qn; i++)
	{
		int b1,b2; scanf("%d%d", &b1, &b2);
		printf("%s", (findFather(b1) == findFather(b2) ? "Yes\n" : "No\n"));
	}
	return 0;
}