Is It A Tree? (并查集)(C++中set的运用)

时间:2019-02-17
本文章向大家介绍Is It A Tree? (并查集)(C++中set的运用),主要包括Is It A Tree? (并查集)(C++中set的运用)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

Is It A Tree? 

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.


In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

本题的本质意思就是判断图中是否存在环,则只需要判断点的数量是否为边的数量+1即可

学会用set了好开森 ^ _ ^

AC代码:

 

#include<cstdio>
#include<algorithm>
#include<set>
using namespace std;
int main()
{
    int a,b;
    int cas=1;
    while(~scanf("%d%d",&a,&b) && (a!=-1 && b!=-1))
    {
        if(a==0 && b==0)
        {
            printf("Case %d is a tree.\n",cas++);
            continue;
        }
        set<int>s;
        s.insert(a);
        s.insert(b);
        int m=1;
        while(scanf("%d%d",&a,&b) && (a || b))
        {
            s.insert(a);
            s.insert(b);//把这两个点放入集合
            m++;//要统计边的条数
        }
        if(s.size()-m==1)//如果满足点的数量减边的条数为1,那么说明不存在环
        {
            printf("Case %d is a tree.\n",cas++);
        }
        else//否则存在环,即不是树
        {
            printf("Case %d is not a tree.\n",cas++);
        }
    }
    return 0;
}