1154 Vertex Coloring (25 分)(C++)

时间:2019-02-11
本文章向大家介绍1154 Vertex Coloring (25 分)(C++),主要包括1154 Vertex Coloring (25 分)(C++)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

解题思路:本题虽然是无向图,但是在存储过程中,只需要存储一条边(存储较大序号到较小序号的一边),因为我们在涂色过程中,需要找该节点的已涂色的邻节点(肯定比它小,比它的节点还没涂色)

#include <iostream>
#include <vector>
#include <set>
using namespace std;
int main(){
    int n, m, k;
    cin>>n>>m;
    std::vector<int> graph[n];
    for(int i = 0; i < m; i++){
        int a, b;
        scanf("%d %d",&a,&b);
        if(a > b)
            swap(a,b);
        graph[b].push_back(a);
    }
    cin>>k;
    for(int j = 0; j < k; j++){
        std::vector<int> color(n);
        set<int>ans;
        bool flag = true;
        for(int i = 0; i < n; i++){
            scanf("%d", &color[i]);
            ans.insert(color[i]);
            for(int u = 0; u < graph[i].size(); u++)
                if(color[graph[i][u]] == color[i]){
                    flag = false;
                    break;
                }
        }
        if(flag == false)
            printf("No\n");
        else
            printf("%d-coloring\n",ans.size());
    }
}