1151 LCA in a Binary Tree (30 分)(C++)

时间:2019-02-11
本文章向大家介绍1151 LCA in a Binary Tree (30 分)(C++),主要包括1151 LCA in a Binary Tree (30 分)(C++)使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

解题思路:这是考试的时候的解法,考场上思维很简单,先记录一下每个节点父亲节点,然后要判断哪个值,就不断地访问它的父亲节点,然后得到该节点到根节点的路径。(PS:a,b如果相同,相同节点的写法是"a is an ancestor of b.",考场上写成了LCA格式,幸亏只有一个1分的测试点有影响)

#include <iostream>
#include <vector>
#include <map>
#include <set>
using namespace std;
vector<int>pre,in,w,father;
map<int,int>flag;
int n, m;
void dfs(int instart, int inend, int prestart, int preend, int id){
    if(prestart > preend)
        return;
    int i = instart;
    while(i <= inend && in[i] != pre[prestart])
        i++;
    father[pre[prestart]] = id;
    dfs(instart, i - 1, prestart + 1, prestart + i - instart, pre[prestart]);
    dfs(i+1, inend, prestart+ i - instart +1, preend, pre[prestart]);
}
int main(){
    scanf("%d %d",&m,&n);   
    pre.resize(n+1);
    in.resize(n+1);
    father.resize(n+1);
    w.resize(n+1);
    for(int i = 1; i <= n; i++){
        scanf("%d",&w[i]);
        in[i] = i;
        flag[w[i]] = i;
    }
    for(int i = 1; i <= n; i++){
        int temp;
        scanf("%d",&temp);
        pre[i] = flag[temp];
    }
    dfs(1, n, 1, n, -1);
    for(int i = 0; i < m; i++){
        set<int>temp;
        int a, b, aid, bid;
        scanf("%d %d",&a,&b);
        if(flag.find(a) == flag.end() && flag.find(b) == flag.end())
            printf("ERROR: %d and %d are not found.\n",a,b);
        else if(flag.find(a) == flag.end())
            printf("ERROR: %d is not found.\n",a);
        else if(flag.find(b) == flag.end())
            printf("ERROR: %d is not found.\n",b);
        else{
            aid = flag[a]; bid = flag[b];
            if(aid == bid){
                printf("%d is an ancestor of %d.\n",b,a);
                break;
            }
            int tempaid = aid;
            while(aid != -1){
                temp.insert(aid);
                aid = father[aid];
                if(aid == bid){
                    printf("%d is an ancestor of %d.\n",b,a);
                    break;
                }
            }
            while(bid != -1){
                bid = father[bid];
                if(tempaid == bid){
                    printf("%d is an ancestor of %d.\n",a,b);
                    break;
                }
                else if(temp.find(bid) != temp.end()){
                    printf("LCA of %d and %d is %d.\n",a,b,w[bid]);
                    break;
                }
            }
        }
    }
}

后来拜读了柳神的博客,不得不感叹我考场上的方法真是太麻烦了,还需要继续努力才可以。

一开始我还在好奇为什么是先写中序遍历,一般PAT给树的遍历,都是先给先序,再给中序。原来是为了确定从哪个序号开始是右子树,方便比较。

所谓ica函数,其实可以看做不完全中序先序转后序的过程,与中序先序转后序不同的是,我们不需要遍历所有节点,只需要确定我们需要的节点在它的左子树还是右子树,或者说就是它本身。

中序遍历将某一个序列划分为 “左子树  根节点  右子树”

①:若a,b都小于根节点序号:遍历左子树

②:若a,b都大于根节点序号:遍历右子树

③:若a,b有一个为该根节点的序号,则其为另一个祖先

④:若a, b各在根节点两边,则该根节点就是我们要找到LCA

#include <iostream>
#include <vector>
#include <map>
using namespace std;
int n, m, a, b, aid, bid;
std::vector<int> pre(10005), in(10005);
map<int, int>pos;
void ica(int inleft, int inright, int preleft){
    if(inleft > inright)
        return;
    int i = pos[pre[preleft]];
    if(i < aid && i < bid)
        ica(i + 1, inright, preleft + i - inleft + 1);
    else if(i > aid && i > bid)
        ica(inleft, i - 1, preleft + 1);
    else if(i == aid)
        printf("%d is an ancestor of %d.\n", a, b);
    else if(i == bid)
        printf("%d is an ancestor of %d.\n", b, a);
    else 
        printf("LCA of %d and %d is %d.\n", a, b, in[i]);
}
int main(){
    scanf("%d %d",&n, &m);
    for(int i = 1; i <= m; ++ i){
        scanf("%d",&in[i]);
        pos[in[i]] = i;
    }
    for(int i = 1; i <= m; ++ i)
        scanf("%d",&pre[i]);
    for(int i = 0; i < n; ++ i){
        scanf("%d %d", &a, &b);
        aid = pos[a];
        bid = pos[b];
        if(aid == 0 && bid == 0)
            printf("ERROR: %d and %d are not found.\n", a, b);
        else if(aid == 0)
            printf("ERROR: %d is not found.\n",a);
        else if(bid == 0)
            printf("ERROR: %d is not found.\n",b);
        else
            ica(1, m, 1);
    }
}