1018. Public Bike Management (30) [Dijkstra算法 + DFS]

时间:2019-01-19
本文章向大家介绍1018. Public Bike Management (30) [Dijkstra算法 + DFS],主要包括1018. Public Bike Management (30) [Dijkstra算法 + DFS]使用实例、应用技巧、基本知识点总结和需要注意事项,具有一定的参考价值,需要的朋友可以参考一下。

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

 

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S

3

, we have 2 different shortest paths:

  1. PBMC -> S 1
    -> S 3
    . In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S 1
    and then take 5 bikes to S 3
    , so that both stations will be in perfect conditions.
  2. PBMC -> S 2
    -> S 3
    . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C

max

(≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S

p

, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C

i

(i=1,…,N) where each C

i

is the current number of bikes at S

i

respectively. Then M lines follow, each contains 3 numbers: S

i

, S

j

, and T

ij

which describe the time T

ij

taken to move betwen stations S

i

and S

j

. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S

1

−>−>S

p

. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S

p

is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5

6 7 0

0 1 1

0 2 1

0 3 3

1 3 1

2 3 1

Sample Output:

3 0->2->3 0

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <set>
#include <string>
#include <cctype>
#include <string.h>
#include <cstdio>
using namespace std;
const int inf=99999999;
int cmax,n,sp,m;
int minNeed=inf,minBack=inf;
int e[510][510],dis[510],weight[510];
bool visit[510];
vector<int> pre[510];
vector<int> temppath,path;
void dfs(int v){
    temppath.push_back(v);
    if(v==0){
        int need=0,back=0;
        for(int i=temppath.size()-1;i>=0;i--){
            int id=temppath[i];
            if(weight[id]>0){
                back+=weight[id];
            }else{
                if(back>abs(weight[id])){
                    back+=weight[id];
                }else{
                    need+=abs(back+weight[id]);
                    back=0;
                }
            }
        }
        if(need<minNeed){
            minNeed=need;
            minBack=back;
            path=temppath;
        }else if(need==minNeed&&back<minBack){
            minBack=back;
            path=temppath;
        }
        temppath.pop_back();
        return;
    }
    for(int i=0;i<pre[v].size();i++)
        dfs(pre[v][i]);
    temppath.pop_back();
}
int main(){
    fill(e[0],e[0]+510*510,inf);
    fill(dis,dis+510,inf);
    cin>>cmax>>n>>sp>>m;
    for(int i=1;i<=n;i++){
        cin>>weight[i];
        weight[i]-=cmax/2;
    }
    for(int i=0;i<m;i++){
        int a,b,c;
        cin>>a>>b>>c;
        e[a][b]=e[b][a]=c;
    }
    dis[0]=0;
    for(int i=0;i<=n;i++){
        int u=-1,minn=inf;
        for(int j=0;j<=n;j++){
            if(visit[j]==false&&dis[j]<minn){
                minn=dis[j];
                u=j;
            }
        }
        if(u==-1) break;
        visit[u]=true;
        for(int v=0;v<=n;v++){
            if(visit[v]==false&&e[u][v]!=inf){
                if(dis[u]+e[u][v]<dis[v]){
                    dis[v]=dis[u]+e[u][v];
                    pre[v].clear();
                    pre[v].push_back(u);
                }else if(dis[u]+e[u][v]==dis[v]){
                    pre[v].push_back(u);
                }
            }
        }
    }
    dfs(sp);
    cout<<minNeed<<" 0";
    for(int i=path.size()-2;i>=0;i--)
        cout<<"->"<<path[i];
    cout<<" "<<minBack;
    return 0;
}