安装mysqlclient遇到的坑 - 提示错误Microsoft Visual C++ 14.0 is required

  时间:2018-11-19
本文章向大家介绍安装mysqlclient时提示错误Microsoft Visual C++ 14.0 is required的解决方法,需要的朋友可以参考一下

在安装mysqlclient的时候出现了以下报错:

解决办法:

1.到提示网址:https://visualstudio.microsoft.com/download/里面下载对应VC++版本安装后继续安装mysqlclient。但是本人没有找到对应文件,故不再过多赘述,这里说下第二种方法。

2.1到https://www.lfd.uci.edu/~gohlke/pythonlibs/找到mysqlclient编译包下载对应版本:

注:前面代表python版本,后面的win代表Python位数。

2.2进入到文件放置的文件夹,比如我是将下载好的文件放在了c:\envs\django1-env并安装:

2.3提示安装成功,问题解决

原文地址:http://www.manongjc.com/article/19238.html